We were using the following:
<Connector port="10443" protocol="org.apache.coyote.http11.Http11NioProtocol"
maxHttpHeaderSize="8192" SSLEnabled="true"
maxThreads="150" minSpareThreads="25"
enableLookups="false" disableUploadTimeout="true"
acceptCount="100" scheme="https" secure="true"
clientAuth="false" sslProtocol="TLS" useBodyEncodingForURI="true"
SSLCertificateFile="C:/Apache24/ssl/SelfSigned2017.crt"
SSLCertificateKeyFile="C:/Apache24/ssl/SelfSigned2017.key"/>
<Connector port="10444" redirectPort="10443" enableLookups="false" protocol="AJP/1.3" URIEncoding="UTF-8"/>
I've tried
server.port=10443
server.secure=true
server.scheme=https
server.ssl.enabled=true
server.ssl.client-auth=want
server.ssl.protocol=TLS
server.ssl.key-store=C:/Program Files/Java/jre1.8.0_121/lib/security/cacerts
but all i get is
Caused by: org.springframework.boot.context.embedded.tomcat.ConnectorStartFailedException: Connector configured to listen on port 10443 failed to start
Update: I got it to start with the following-
server.port=10444
server.redirect-port=10443
server.ssl.protocol=AJP/1.3
server.additional-connector.1.port=10443
server.additional-connector.1.secure=true
server.additional-connector.1.scheme=https
server.additional-connector.1.ssl.enabled=true
server.additional-connector.1.ssl.protocol=TLSv1.2
server.additional-connector.1.ssl.key-store=C:/Atlassian/devkeys.jks
server.additional-connector.1.ssl.key-store-password=changeit
server.additional-connector.1.ssl.key-password=changeit
server.additional-connector.1.ssl.key-alias=devcode
server.additional-connector.1.ssl.client-auth=want
server.additional-connector.1.ssl.key-store-type=jks
But now the issue is the AJP redirect. We're using apache as the proxy. I tried just server.protocol=AJP/1.3, but then it refuses to start.
Update 2: And then I find out that AJP is no longer supported. I seem to have got it working with making apache just proxy to https://:10443 for the moment.