Searched on how to resolve this but could not get exact solution.
JIRA Version : JIRA v7.2.7
Please let me know how to resolve this issue.
Thanks,
Krithica
We can't see the images. Please tell us what the errors are?
These are the errors.
You will need to read your log file to find out what is going wrong there.
I could not find anything from log file because only these lines i get.
"2017-08-23 23:20:46,082 http-bio-8443-exec-11180 url:/secure/QuickEditIssue.jspa username:x0251221 ERROR x0251221 1400x7921518x3 tu0g4r 172.22.155.46 /secure/QuickEditIssue.jspa [c.a.qtm.utils.LoggerUtils] Issue DC_CM-8957 has been resolved atnull2017-08-23 23:20:46,082 http-bio-8443-exec-11180 url:/secure/QuickEditIssue.jspa username:x0251221 ERROR x0251221 1400x7921518x3 tu0g4r 172.22.155.46 /secure/QuickEditIssue.jspa [c.a.qtm.utils.LoggerUtils] sprint value for customField ---> customfield_10000"
No clue from these except it is caused from "Sprint" field. Please help.
Did you unlock the sprint field? This error is usually caused because of that.
It has been resolved in version 7.4.1 [Ticket | https://jira.atlassian.com/browse/JSWSERVER-11849]
Can You please let me know the steps to unlock the "Sprint" field.
Thanks
Would you please elabroate on why are you wanting to change the default sprint field?It is locked because of some purpose, and people (Nic) more enlightened than me would argue that it'd be a mistake unlocking the field.
Nonetheless, following are the steps to unlock a locked field in JIRA.
Run the following query via database to determine the JIRA Software custom field IDs
SELECT id,customfieldtypekey,cfname from customfield where customfieldtypekey like 'com.pyxis.greenhopper.jira%';
It should return a result like the following:
id | customfieldtypekey | cfname-------+--------------------------------------------------------------------+------------------------- 10204 | com.pyxis.greenhopper.jira:gh-global-rank | Rank 10205 | com.pyxis.greenhopper.jira:gh-sprint | Sprint 10206 | com.pyxis.greenhopper.jira:gh-epic-link | Epic Link 10207 | com.pyxis.greenhopper.jira:gh-epic-label | Epic Name 10208 | com.pyxis.greenhopper.jira:gh-epic-status | Epic Status 10209 | com.pyxis.greenhopper.jira:gh-epic-color | Epic Colour 10211 | com.pyxis.greenhopper.jira:greenhopper-releasedmultiversionhistory | Release Version History
You will have to match the id of the field you want to unlock with the according entry (in this case 10205) in managedconfigurationitem table's item_id column.
SELECT * from managedconfigurationitem;
id | item_id | item_type | managed | access_level | source | description_key-------+-------------------+--------------+---------+--------------+----------------------------------------------------+---------------------------- 10000 | customfield_10204 | CUSTOM_FIELD | true | LOCKED | com.pyxis.greenhopper.jira:reference-select-locked | gh.customfield.locked.desc 10001 | customfield_10205 | CUSTOM_FIELD | true | LOCKED | com.pyxis.greenhopper.jira:reference-select-locked | gh.customfield.locked.desc 10002 | customfield_10206 | CUSTOM_FIELD | true | LOCKED | com.pyxis.greenhopper.jira:reference-select-locked | gh.customfield.locked.desc 10003 | customfield_10207 | CUSTOM_FIELD | true | LOCKED | com.pyxis.greenhopper.jira:reference-select-locked | gh.customfield.locked.desc 10004 | customfield_10208 | CUSTOM_FIELD | true | LOCKED | com.pyxis.greenhopper.jira:reference-select-locked | gh.customfield.locked.desc 10005 | customfield_10209 | CUSTOM_FIELD | true | LOCKED | com.pyxis.greenhopper.jira:reference-select-locked | gh.customfield.locked.desc
You will need to set the managed column to false of any field you want to unlock. For example, the below will unlock Sprint field according to the ids above:
UPDATE managedconfigurationitem set managed='false' where item_id in ('customfield_10205');
Note: After the above change the 'access_level' column will remain with the 'LOCKED' value, but the custom fields will be unlocked from the UI.
Make the required changes to the fields.Lock the fields that were unlocked by setting the managed column to true. For example, the below will lock Sprint:
UPDATE managedconfigurationitem set managed='true' where item_id in ('customfield_10205'');
Note: These fields will be locked again once you restart services.
Without unlocking the field how can i resolve the error? Can you please provide me with other best solutions to resolve this?
It looks like you're new here. Sign in or register to get started.