Error message below:
Unable to start up Confluence. Fatal error during startup sequence: confluence.lifecycle.core:mananagedjobs (Start and stop the Managed Scheduled Jobs) - org.springframework.jdbc.UncategorizedSQLException: Hibernate operation: Could not execute query; uncategorized SQLException for SQL []; SQL state [72000]; error code [1555]; ORA-01555: snapshot too old: rollback segment number with name "" too small ORA-22924: snapshot too old ; nested exception is java.sql.SQLException: ORA-01555: snapshot too old: rollback segment number with name "" too small ORA-22924: snapshot too old
I understand Confluence will not start and there is an error:
ORA-01555: snapshot too old
Please see the resolution on this knowledgebase article:
Confluence Fails with ORA-01555 Error
I look forward to hearing how it goes.
Hi Ann Worley,
Even we are not able to access the confluence & facing the same issue.
History:
we experienced a loss of our VM server that host our Confluence instance. We have restarted the server and confluence service.We restarted the DB server with no issue but the confluence application it self is not starting properly below is the error we are getting.
You cannot access Confluence at present. Look at the table below to identify the reasons.Type Description Exception Level Timestartup Unable to start up Confluence. Fatal error during startup sequence: fatal 2018-05-31 13:42:44 confluence.lifecycle.core:mananagedjobs (Start and stop the Managed Scheduled Jobs) - org.springframework.transaction.UnexpectedRollbackException: Transaction rolled back because it has been marked as rollback-onlyYour server id is: XXXX-XXXX-XXXX-XXXX
As per the atlassian_confluence.log file able to find the solution link
https://confluence.atlassian.com/confkb/confluence-fails-with-ora-01555-error-300812340.html?_ga=2.172935466.802235838.1528102568-665638832.1518597719
But can we have the clear steps to resolve this issue please.
atlassian_confluence.log
2018-06-04 12:54:37,614 ERROR [Caesium-1-2] [engine.jdbc.spi.SqlExceptionHelper] logExceptions ORA-01555: snapshot too old: rollback segment number with name "" too smallORA-22924: snapshot too old2018-06-04 12:54:37,637 ERROR [Caesium-1-2] [impl.schedule.caesium.JobRunnerWrapper] runJob Scheduled job LaasPerformanceLoggingJob#LaasPerformanceLoggingJob jobToBeExecuted failed to runorg.springframework.transaction.UnexpectedRollbackException: Transaction rolled back because it has been marked as rollback-onlyCaused by: java.sql.SQLException: ORA-01555: snapshot too old: rollback segment number with name "" too smallORA-22924: snapshot too old at oracle.jdbc.driver.T4CTTIoer.processError(T4CTTIoer.java:447) at oracle.jdbc.driver.T4CTTIoer.processError(T4CTTIoer.java:389) at oracle.jdbc.driver.T4CTTIoer.processError(T4CTTIoer.java:382) at oracle.jdbc.driver.T4C8TTILob.processError(T4C8TTILob.java:792) at oracle.jdbc.driver.T4CTTIfun.receive(T4CTTIfun.java:513) at oracle.jdbc.driver.T4CTTIfun.doRPC(T4CTTIfun.java:227) at oracle.jdbc.driver.T4C8TTIClob.read(T4C8TTIClob.java:247) at oracle.jdbc.driver.T4CConnection.getChars(T4CConnection.java:3276) at oracle.sql.CLOB.getChars(CLOB.java:459) at oracle.sql.CLOB.getSubString(CLOB.java:321) at org.springframework.jdbc.support.lob.OracleLobHandler.getClobAsString(OracleLobHandler.java:255) at com.atlassian.hibernate.BucketClobStringType.nullSafeGet(BucketClobStringType.java:126) at org.hibernate.type.CustomType.nullSafeGet(CustomType.java:119) at org.hibernate.type.AbstractType.hydrate(AbstractType.java:82) at org.hibernate.persister.entity.AbstractEntityPersister.hydrate(AbstractEntityPersister.java:2775) at org.hibernate.loader.Loader.loadFromResultSet(Loader.java:1741) at org.hibernate.loader.Loader.instanceNotYetLoaded(Loader.java:1667) at org.hibernate.loader.Loader.getRow(Loader.java:1556) at org.hibernate.loader.Loader.getRowFromResultSet(Loader.java:740) at org.hibernate.loader.Loader.processResultSet(Loader.java:985) at org.hibernate.loader.Loader.doQuery(Loader.java:943) at org.hibernate.loader.Loader.doQueryAndInitializeNonLazyCollections(Loader.java:349) at org.hibernate.loader.Loader.doList(Loader.java:2615) ... 53 more2018-06-04 12:54:38,267 INFO [CrowdUsnChangedCacheRefresher:thread-2] [directory.ldap.cache.UsnChangedCacheRefresher] call found [ 53 ] remote groups in [ 745ms ]2018-06-04 12:54:38,385 ERROR [localhost-startStop-1] [engine.jdbc.spi.SqlExceptionHelper] logExceptions ORA-01555: snapshot too old: rollback segment number with name "" too smallORA-22924: snapshot too old
Thanksa
Sanjeev Kumar N
Hi Sanjeev,
It looks like there are resolution steps on the article you linked: Confluence Fails with ORA-01555 Error. Please let me know where in the steps the process breaks down for you and what errors you are seeing when you follow the resolution.
Thanks,
Ann
Ann,
Thanks for solution, we were able to resolve the issue.Confluence is now accessible.
Issues was related to DB, as per the doc DB admin were able to resolve.
Thanks
It looks like you're new here. Sign in or register to get started.