I added some new groups into the Active Directory last week in preparation for using a those new groups to restrict Confluence access.
None of them are showing up in group searches within Confluence even though all tests for LDAP connectivity work ok.
I have run the connection tests and also disabled and enabled the Active Directory in User Directories without any success.
All syncs seems to work, but when I check the log I can see:
Unable to find user mapping for hassenh
It turns out that a number of AD user entries cause issues and java exceptions when queried
Nothing appear to be wrong with these entries in the AD though :-(