I am testing an upgrade from Bitbucket Server 4.14 to 5.2.2 on Windows. After the upgrade, Bitbucket fails to start because of a lack of permisions on the bitbucket.properties file. The ACLs are the same before and after the upgrade:
BUILTIN\Administrators:(R,W,D,WDAC,WO,DC)
Granting the atlbitbucket account read access allows Bitbucket to start. Does this account require any other permissions? Why the change in required access in the new version?