Hi,
I upgraded a copy of our production server from version 5.8.9 to version 6.3.1 in a staging environment.
Now Confluence is dying sporadically shortly after the boot process has finished for no apparent reason. This happens about every 5th to 10th boot. The only errors in <confluence_home>/logs/atlassian-confluence.log are:
2017-07-24 14:10:14,646 ERROR [ThreadPoolAsyncTaskExecutor::Thread 13] [spring.scanner.extension.ComponentImportBeanFactoryPostProcessor] postProcessBeanFactory Unable to load class 'com.atlassian.bitbucket.auth.RememberMeService' for component importation purposes. Skipping...
2017-07-24 14:10:14,652 ERROR [ThreadPoolAsyncTaskExecutor::Thread 13] [spring.scanner.extension.ComponentImportBeanFactoryPostProcessor] postProcessBeanFactory Unable to load class 'com.atlassian.jira.config.properties.ApplicationProperties' for component importation purposes. Skipping...
As these error messages can also be seen during successful Confluence startups I suppose that they are not the cause of the problem.
According to /var/log/syslog the service is started normally:
Jul 24 14:09:19 confluencetest confluence[1041]: To run Confluence in the foreground, start the server with start-confluence.sh -fg
Jul 24 14:09:19 confluencetest confluence[1041]: executing using dedicated user: confluence
Jul 24 14:09:19 confluencetest confluence[1041]: If you encounter issues starting up Confluence, please see the Installation guide at http://confluence.atlassian.com/display/DOC/Confluence+Installation+Guide
Jul 24 14:09:19 confluencetest confluence[1041]: Server startup logs are located in /opt/atlassian/confluence/logs/catalina.out
Jul 24 14:09:19 confluencetest confluence[1041]: ---------------------------------------------------------------------------
Jul 24 14:09:19 confluencetest confluence[1041]: Using Java: /opt/atlassian/confluence/jre//bin/java
Jul 24 14:09:19 confluencetest systemd[1]: Started MySQL Community Server.
Jul 24 14:09:20 confluencetest confluence[1041]: 2017-07-24 14:09:20,756 INFO [main] [atlassian.confluence.bootstrap.SynchronyProxyWatchdog] A Context element for ${confluence.context.path}/synchrony-proxy is found in /opt/atlassian/confluence/conf/server.xml. No further action is required
Jul 24 14:09:20 confluencetest confluence[1041]: ---------------------------------------------------------------------------
Jul 24 14:09:20 confluencetest confluence[1041]: Using CATALINA_BASE: /opt/atlassian/confluence
Jul 24 14:09:20 confluencetest confluence[1041]: Using CATALINA_HOME: /opt/atlassian/confluence
Jul 24 14:09:20 confluencetest confluence[1041]: Using CATALINA_TMPDIR: /opt/atlassian/confluence/temp
Jul 24 14:09:20 confluencetest confluence[1041]: Using JRE_HOME: /opt/atlassian/confluence/jre/
Jul 24 14:09:20 confluencetest confluence[1041]: Using CLASSPATH: /opt/atlassian/confluence/bin/bootstrap.jar:/opt/atlassian/confluence/bin/tomcat-juli.jar
Jul 24 14:09:20 confluencrtest confluence[1041]: Using CATALINA_PID: /opt/atlassian/confluence/work/catalina.pid
Jul 24 14:09:20 confluencetest confluence[1041]: Tomcat started.
Has anyone experienced a similar behaviour of a Confluence server?
As I could not find a solution to this behaviour after investigating the problem for a longer period of time and searching the Atlassian documentation, knowledgebase etc. any help on this is appreciated!