I've just upgraded our BitBucket Server to 5.2.2 and it won't start with an error message: "The database, as currently configured, is not accessible. Bitbucket is configured to use the mysql driver (com.mysql.jdbc.Driver) but it is not available.".
This is not the first time I was upgrading the BitBucket Server. As it was with the last time I was upgrading it, I've put the latest jdbc driver (mysql-connector-java-5.1.43-bin.jar) in the /opt/atlassian/bitbucket/5.2.2/lib folder. It doesn't matter if I start it with service atlbitbucket start or 5.2.2/bin/start-bitbucket.sh commands, the error is always there.
Is this a known issue and can it be resolved?