My specific situation is that I have a bitbucket pipelines file that uses an AWS-CLI docker image as a service container. My pipeline step script runs `aws` commands to set some configurations before running an AWS S3 sync of files generated on the main container to a specified endpoint in S3. The problem is that I end up with the following error:
bash: aws: command not found
I defined the service definition to use the `xueshanf/awscli` image. Am I simply using the wrong one, or do I need to pass additional Docker run options in the pipeline file? I didn't see any options for that in the documentation.