I'm new on Atlassian. I followed instrunctions for setting up Atlassian.After installatians my configuration is this (from jira_home/log/atlassian-jira.log):
Application Server : Apache Tomcat/8.0.36 - Servlet API 3.1
Java Version : 1.8.0_25 - Oracle Corporation
Current Working Directory : C:\Users\Ahmet\Developing Env\AtlassianProjects\JiraApp\target\container\tomcat8x\cargo-jira-home
Maximum Allowable Memory : 455MB
Total Memory : 146MB
Free Memory : 101MB
Used Memory : 45MB
Memory Pool: Code Cache : Code Cache: init = 2555904(2496K) used = 9799040(9569K) committed = 9961472(9728K) max = 251658240(245760K)
Memory Pool: Metaspace : Metaspace: init = 0(0K) used = 21888232(21375K) committed = 22675456(22144K) max = -1(-1K)
Memory Pool: Compressed Class Space : Compressed Class Space: init = 0(0K) used = 2524280(2465K) committed = 2752512(2688K) max = 1073741824(1048576K)
Memory Pool: PS Eden Space : PS Eden Space: init = 34078720(33280K) used = 20981768(20490K) committed = 59244544(57856K) max = 169345024(165376K)
Memory Pool: PS Survivor Space : PS Survivor Space: init = 5242880(5120K) used = 0(0K) committed = 4718592(4608K) max = 4718592(4608K)
Memory Pool: PS Old Gen : PS Old Gen: init = 89653248(87552K) used = 27604128(26957K) committed = 89653248(87552K) max = 358088704(349696K)
JVM Input Arguments : -Xmx512m -XX:MaxPermSize=256m -Xms128m -XX:PermSize=48m -Dbaseurl=http://Decompiler:2990/jira -Dplugin.root.directories=C:\Users\Ahmet\Developing Env\AtlassianProjects\JiraApp -Dcargo.servlet.uriencoding=UTF-8 -Dcom.atlassian.jira.startup.LauncherContextListener.SYNCHRONOUS=true -Dplugin.resource.directories=C:\Users\Ahmet\Developing Env\AtlassianProjects\JiraApp\src\main\resources,C:\Users\Ahmet\Developing Env\AtlassianProjects\JiraApp\src\test\resources -Datlassian.dev.mode=true -Djava.awt.headless=true -Djira.home=C:/Users/Ahmet/Developing Env/AtlassianProjects/JiraApp/target/jira/home -Dcargo.datasource.datasource=cargo.datasource.url=jdbc:h2:file:C:/Users/Ahmet/Developing Env/AtlassianProjects/JiraApp/target/jira/home/database/h2db|cargo.datasource.driver=org.h2.Driver|cargo.datasource.username=sa|cargo.datasource.password=|cargo.datasource.jndi=jdbc/JiraDS -Datlassian.sdk.version=6.2.11 -Dcatalina.home=C:\Users\Ahmet\Developing Env\AtlassianProjects\JiraApp\target\container\tomcat8x\apache-tomcat-8.0.36 -Dcatalina.base=C:\Users\Ahmet\Developing Env\AtlassianProjects\JiraApp\target\container\tomcat8x\cargo-jira-home -Djava.io.tmpdir=C:\Users\Ahmet\Developing Env\AtlassianProjects\JiraApp\target\container\tomcat8x\cargo-jira-home/temp -Djava.util.logging.manager=org.apache.juli.ClassLoaderLogManager -Djava.util.logging.config.file=C:\Users\Ahmet\Developing Env\AtlassianProjects\JiraApp\target\container\tomcat8x\cargo-jira-home/conf/logging.properties
Java Compatibility Information : JIRA version = 7.2.2, Java Version = 1.8.0_25
And my Atlassian-SDK parameters :
ATLAS Version: 6.2.14
ATLAS Home: C:\Applications\Atlassian\atlassian-plugin-sdk-6.2.14
ATLAS Scripts: C:\Applications\Atlassian\atlassian-plugin-sdk-6.2.14\bin
ATLAS Maven Home: C:\Applications\Atlassian\atlassian-plugin-sdk-6.2.14\apache-maven-3.2.1
AMPS Version: 6.2.11
--------
Executing: "C:\Applications\Atlassian\atlassian-plugin-sdk-6.2.14\apache-maven-3.2.1\bin\mvn.bat" --
version -gs C:\Applications\Atlassian\atlassian-plugin-sdk-6.2.14\apache-maven-3.2.1/conf/settings.xml
* Java HotSpot(TM) 64-Bit Server VM warning: ignoring option MaxPermSize=256M; support was removed in 8.0
* Apache Maven 3.2.3 (33f8c3e1027c3ddde99d3cdebad2656a31e8fdf4; 2014-08-11T23:58:10+03:00)
* Maven home: C:\Users\Ahmet\Developing Env\Apache Maven 3.2.3
* Java version: 1.8.0_25, vendor: Oracle Corporation
* Java home: C:\Program Files\Java\jdk1.8.0_25\jre
* Default locale: tr_TR, platform encoding: Cp1254
* OS name: "windows 8.1", version: "6.3", arch: "amd64", family: "dos"
After i run this command atlas-create-jira-plugin, there is an Jira instance a directory. And than i run atlas-run command and visit localhost:2990/jira; i get this error
Jıra Startup Failed Error
The following plugins are required by JIRA, but have not been started:
- JIRA Projects Plugin (com.atlassian.jira.jira-projects-plugin)
- Atlassian OAuth Consumer Plugin (com.atlassian.oauth.consumer) and more
And atlassian-jira.log has so many Errors like this (it cant create database and exeute queries)
WARN [o.o.c.entity.jdbc.DatabaseUtil] Entity "Action" has no table in the database
ERROR [o.o.c.entity.jdbc.DatabaseUtil] Could not create table "PUBLIC.jiraaction"
ERROR [o.o.c.entity.jdbc.DatabaseUtil] SQL Exception while executing the following:
CREATE TABLE PUBLIC.jiraaction (ID BIGINT NOT NULL, issueid BIGINT, AUTHOR VARCHAR, actiontype VARCHAR, actionlevel VARCHAR, rolelevel BIGINT, actionbody VARCHAR, CREATED TIMESTAMP, UPDATEAUTHOR VARCHAR, UPDATED TIMESTAMP, actionnum BIGINT, CONSTRAINT PK_jiraaction PRIMARY KEY (ID))
Error was: org.h2.jdbc.JdbcSQLException: Table "JIRAACTION" already exists; SQL statement:
CREATE TABLE PUBLIC.jiraaction (ID BIGINT NOT NULL, issueid BIGINT, AUTHOR VARCHAR, actiontype VARCHAR, actionlevel VARCHAR, rolelevel BIGINT, actionbody VARCHAR, CREATED TIMESTAMP, UPDATEAUTHOR VARCHAR, UPDATED TIMESTAMP, actionnum BIGINT, CONSTRAINT PK_jiraaction PRIMARY KEY (ID)) [42101-185]
WARN [o.o.c.entity.jdbc.DatabaseUtil] Entity "Application" has no table in the database
ERROR [o.o.c.entity.jdbc.DatabaseUtil] Could not create table "PUBLIC.cwd_application"
ERROR [o.o.c.entity.jdbc.DatabaseUtil] SQL Exception while executing the following:
CREATE TABLE PUBLIC.cwd_application (ID BIGINT NOT NULL, application_name VARCHAR, lower_application_name VARCHAR, created_date TIMESTAMP, updated_date TIMESTAMP, active INTEGER, description VARCHAR, application_type VARCHAR, credential VARCHAR, CONSTRAINT PK_cwd_application PRIMARY KEY (ID))
Error was: org.h2.jdbc.JdbcSQLException: Table "CWD_APPLICATION" already exists; SQL statement:
CREATE TABLE PUBLIC.cwd_application (ID BIGINT NOT NULL, application_name VARCHAR, lower_application_name VARCHAR, created_date TIMESTAMP, updated_date TIMESTAMP, active INTEGER, description VARCHAR, application_type VARCHAR, credential VARCHAR, CONSTRAINT PK_cwd_application PRIMARY KEY (ID)) [42101-185]
And on a line i see this
h2 is an in-memory database, and susceptible to corruption when abnormally terminated.
DO NOT USE IN PRODUCTION, please switch to a regular database.
WARN [c.a.p.o.f.transform.stage.ScanDescriptorForHostClassesStage] The plugin 'atlassian-universal-plugin-manager-plugin-2.20.7.jar' uses a package 'org.apache.velocity.tools.generic' that is also exported by the application. It is highly recommended that the plugin use its own packages.
WARN [c.a.p.osgi.util.OsgiHeaderUtil] removing duplicate import package com.atlassian.jira.blueprint.api~ for plugin com.atlassian.jira-core-project-templates - it is likely that a duplicate package was supplied in the OSGi instructions in the plugin's MANIFEST.MF
WARN [c.a.p.osgi.util.OsgiHeaderUtil] removing duplicate import package com.atlassian.jira.projects.shortcuts~ for plugin com.atlassian.jira-core-project-templates - it is likely that a duplicate package was supplied in the OSGi instructions in the plugin's MANIFEST.MF
WARN [c.a.p.o.f.transform.stage.GenerateManifestStage] Manifest contains a 'Spring-Context:' header with a timeout, namely '*;timeout:=60'. This can cause problems as the timeout is server specific. Use the header 'Spring-Context: *' in the jar 'pdkinstall-plugin-0.6.jar'.
It cant enable plugins
INFO [c.a.plugin.util.WaitUntil] Plugins that have yet to be enabled: (155): [tac.jira core.languages.ja_JP, com.atlassian.jira.jira-core-reports-plugin, ...... com.atlassian.streams.streams-spi], 60 seconds remaining
INFO [c.a.plugin.util.WaitUntil] Plugins that have yet to be enabled: (155): [tac.jira core.languages.ja_JP, com.atlassian.jira.jira-core-reports-plugin, ...... com.atlassian.streams.streams-spi], 0 seconds remaining
And more Error cause of it could not create database
ERROR [c.a.jira.startup.LauncherContextListener]
Unable to start JIRA.
com.atlassian.jira.exception.DataAccessException:
org.ofbiz.core.entity.GenericDataSourceException:
SQL Exception while executing the following:SELECT ID, TYPE, REQUEST_TIME, START_TIME, COMPLETION_TIME, STATUS, EXECUTION_NODE_ID, QUERY FROM PUBLIC.reindex_request WHERE STATUS=? ORDER BY REQUEST_TIME
(Column "QUERY" not found; SQL statement:
SELECT ID, TYPE, REQUEST_TIME, START_TIME, COMPLETION_TIME, STATUS, EXECUTION_NODE_ID, QUERY FROM PUBLIC.reindex_request WHERE STATUS=? ORDER BY REQUEST_TIME [42122-185])
And last error
WARNING: 'Apache Tomcat/8.0.36' server and the 'org.apache.jasper.runtime.BodyContentImpl.LIMIT_BUFFER' system property is not set to true! This can result in OutOfMemoryErrors. For more information please see {2}. When i compare this log whit a log comes from Running Jira instance: Biggest diffrences are about database errors