I have UPM v2.22.1 on Confluence v6.1.2 behind an apache proxy.
When I try to access Manage Add-ons, the page loads but the loader spins forever and after about 5 mins, I get the error message "An unexpected error occurred. Please check the logs".
JS Console has this : Failed to load resource: the server responded with a status of 502 (Proxy Error)
Logs (relevant section) :
-- referer: http://<host>/confluence/plugins/servlet/upm | url: /confluence/rest/plugins/1.0/installed-marketplace | traceId: 78c77a2f3b3f4a52 | userName: arvind
2017-04-24 07:34:54,362 INFO [http-nio-8090-exec-25] [atlassian.plugin.manager.DefaultPluginManager] broadcastPluginDisabling Disabling com.atlassian.upm.atlassian-universal-plugin-manager-selfupdate-plugin
Also, baseURL is set correctly.
Any ideas?