My Pipelines configuration gets rejected with the following message:
The 'environment' section in your bitbucket-pipelines.yml file must be a map.
Using the docs, I created the following yml:
pipelines:
branches:
main:
- step:
image: php
script:
- php -v
- apt-get update && apt-get install -y unzip
- curl -sS https://getcomposer.org/installer | php -- --install-dir=/usr/local/bin --filename=composer
- composer -V
- composer install
- bin/console doctrine:schema:create
- bin/console doctrine:fixtures:load
- vendor/bin/phpunit
services:
- mysql
definitions:
services:
mysql:
image: mysql
environment:
MYSQL_DATABASE: tournament
MYSQL_RANDOM_ROOT_PASSWORD: yes
MYSQL_USERNAME: tournament_user
MYSQL_PASSWORD: tournament_passwordWhat's wrong with this configuration file? Why is it rejected?