I receive the following error when trying to configure JIRA/Confluence as trusted applications to one another:
Unable to retrieve the application's certificate: Invalid response code of 500 returned from:http://www.xxxx:8090/confluence/admin/appTrustCertificate
It appears the following error may have something to do with it:
2013-07-08 18:16:27,789 WARN [http-8090-7] [applinks.core.auth.AuthenticationConfigurator] configureAuthenticationForApplicationLink Failed to initialize authentication provider 'com.atlassian.applinks.api.auth.types.TrustedAppsAuthenticationProvider'. Trying to use another one.
-- url: /confluence/rest/applinks/1.0/applicationlinkForm/createAppLink | userName: sysadmin | referer: http://xxxx.xxxx.xxxx.xxxx.xxxx:8090/confluence/admin/listapplicationlinks.action
com.atlassian.applinks.spi.auth.AuthenticationConfigurationException: Error configuring peer: Response code: 500:
Any ideas how to resolve this? I believe it's preventing some gadgets from working correctly (Specifically Jira Issues Calendar).
Thanks,
Trevor