I am not able to get to http://localhost:8090 or http://localhost:8090/confluence
I have Jira running and installed on Port 8080.
This is installed on CentOS 6.4
I have read that there must be a seperate instance of Tomcat for both Jira and Confluence.
I did however install Confluence from the whole package provided by Atlassian.
Any help on what I'm doing wrong would be greatly appreciated.
Confulence is stuck here:
"bash start-confluence.sh -fg
executing using dedicated user: confluence If you encounter issues starting up Confluence Standalone, please see the Installation guide at http://confluence.atlassian.com/display/DOC/Confluence+Installation+Guide
Server startup logs are located in /opt/atlassian/confluence/logs/catalina.out
Using CATALINA_BASE: /opt/atlassian/confluence
Using CATALINA_HOME: /opt/atlassian/confluence
Using CATALINA_TMPDIR: /opt/atlassian/confluence/temp
Using JRE_HOME: /opt/atlassian/confluence/jre/
Using CLASSPATH: /opt/atlassian/confluence/bin/bootstrap.jar
Using CATALINA_PID: /opt/atlassian/confluence/work/catalina.pid
Apr 21, 2013 6:15:43 PM org.apache.tomcat.util.digester.SetPropertiesRule begin
WARNING: [SetPropertiesRule]{Server} Setting property 'debug' to '0' did not find a matching property.
Apr 21, 2013 6:15:43 PM org.apache.tomcat.util.digester.SetPropertiesRule begin
WARNING: [SetPropertiesRule]{Server/Service/Engine} Setting property 'debug' to '0' did not find a matching property.
Apr 21, 2013 6:15:43 PM org.apache.tomcat.util.digester.SetPropertiesRule begin
WARNING: [SetPropertiesRule]{Server/Service/Engine/Host} Setting property 'debug' to '0' did not find a matching property.
Apr 21, 2013 6:15:43 PM org.apache.tomcat.util.digester.SetPropertiesRule begin
WARNING: [SetPropertiesRule]{Server/Service/Engine/Host/Context} Setting property 'debug' to '0' did not find a matching property.
Apr 21, 2013 6:15:43 PM org.apache.coyote.http11.Http11Protocol init
INFO: Initializing Coyote HTTP/1.1 on http-8090 Apr 21, 2013 6:15:43 PM org.apache.catalina.startup.Catalina load
INFO: Initialization processed in 525 ms Apr 21, 2013 6:15:43 PM org.apache.catalina.core.StandardService start
INFO: Starting service Tomcat-Standalone Apr 21, 2013 6:15:44 PM org.apache.catalina.core.StandardEngine start
INFO: Starting Servlet Engine: Apache Tomcat/6.0.35
2013-04-21 18:15:46,483 INFO [main] [com.atlassian.confluence.lifecycle] contextInitialized Starting Confluence 5.3.1 [build 4528 based on commit hash eaa35c45b124c018e6c8bf70a069c3c2f63fd66d]
Apr 21, 2013 6:16:01 PM org.apache.coyote.http11.Http11Protocol start
INFO: Starting Coyote HTTP/1.1 on http-8090 Apr 21, 2013 6:16:01 PM org.apache.catalina.startup.Catalina start
INFO: Server startup in 17364 ms"
___________________________________________________________________________
it became unresponsive after this.
Below is the log for catalina.out:
"Apr 21, 2013 6:12:58 PM org.apache.coyote.http11.Http11Protocol pause
INFO: Pausing Coyote HTTP/1.1 on http-8090 Apr 21, 2013 6:12:59 PM org.apache.catalina.core.StandardService stop
INFO: Stopping service Tomcat-Standalone Apr 21, 2013 6:12:59 PM org.apache.catalina.loader.WebappClassLoader clearReferencesJdbc
SEVERE: The web application [] registered the JDBC driver [org.hsqldb.jdbc.JDBCDriver] but failed to unregister it when the web application was stopped. To prevent a memory leak, the JDBC Driver has been forcibly unregistered.
Apr 21, 2013 6:12:59 PM org.apache.catalina.loader.WebappClassLoader clearReferencesJdbc
SEVERE: The web application [] registered the JDBC driver [org.postgresql.Driver] but failed to unregister it when the web application was stopped. To prevent a memory leak, the JDBC Driver has been forcibly unregistered.
Apr 21, 2013 6:12:59 PM org.apache.catalina.loader.WebappClassLoader clearThreadLocalMap
SEVERE: The web application [] created a ThreadLocal with key of type [java.lang.ThreadLocal] (value [java.lang.ThreadLocal@4c9d7a2e]) and a value of type [org.dom4j.DocumentFactory] (value [org.dom4j.DocumentFactory@76c0894d]) but failed to remove it when the web application was stopped. This is very likely to create a memory leak.
log4j:ERROR LogMananger.repositorySelector was null likely due to error in class reloading, using NOPLoggerRepository.
Apr 21, 2013 6:13:00 PM org.apache.coyote.http11.Http11Protocol destroy
INFO: Stopping Coyote HTTP/1.1 on http-8090 Apr 21, 2013 6:13:11 PM org.apache.tomcat.util.digester.SetPropertiesRule begin
WARNING: [SetPropertiesRule]{Server} Setting property 'debug' to '0' did not find a matching property.
Apr 21, 2013 6:13:11 PM org.apache.tomcat.util.digester.SetPropertiesRule begin
WARNING: [SetPropertiesRule]{Server/Service/Engine} Setting property 'debug' to '0' did not find a matching property.
Apr 21, 2013 6:13:11 PM org.apache.tomcat.util.digester.SetPropertiesRule begin
WARNING: [SetPropertiesRule]{Server/Service/Engine/Host} Setting property 'debug' to '0' did not find a matching property.
Apr 21, 2013 6:13:11 PM org.apache.tomcat.util.digester.SetPropertiesRule begin
WARNING: [SetPropertiesRule]{Server/Service/Engine/Host/Context} Setting property 'debug' to '0' did not find a matching property.
Apr 21, 2013 6:13:11 PM org.apache.coyote.http11.Http11Protocol init
INFO: Initializing Coyote HTTP/1.1 on http-8090 Apr 21, 2013 6:13:11 PM org.apache.catalina.startup.Catalina load
INFO: Initialization processed in 522 ms Apr 21, 2013 6:13:11 PM org.apache.catalina.core.StandardService start
INFO: Starting service Tomcat-Standalone Apr 21, 2013 6:13:11 PM org.apache.catalina.core.StandardEngine start
INFO: Starting Servlet Engine: Apache Tomcat/6.0.35
2013-04-21 18:13:14,454 INFO [main] [com.atlassian.confluence.lifecycle] contextInitialized Starting Confluence 5.3.1 [build 4528 based on commit hash eaa35c45b124c018e6c8bf70a069c3c2f63fd66d]
Apr 21, 2013 6:13:29 PM org.apache.coyote.http11.Http11Protocol start
INFO: Starting Coyote HTTP/1.1 on http-8090 Apr 21, 2013 6:13:29 PM org.apache.catalina.startup.Catalina start
INFO: Server startup in 17612 ms
Apr 21, 2013 6:15:35 PM org.apache.coyote.http11.Http11Protocol pause
INFO: Pausing Coyote HTTP/1.1 on http-8090 Apr 21, 2013 6:15:36 PM org.apache.catalina.core.StandardService stop
INFO: Stopping service Tomcat-Standalone Apr 21, 2013 6:15:36 PM org.apache.catalina.loader.WebappClassLoader clearReferencesJdbc
SEVERE: The web application [] registered the JDBC driver [org.hsqldb.jdbc.JDBCDriver] but failed to unregister it when the web application was stopped. To prevent a memory leak, the JDBC Driver has been forcibly unregistered.
Apr 21, 2013 6:15:36 PM org.apache.catalina.loader.WebappClassLoader clearReferencesJdbc
SEVERE: The web application [] registered the JDBC driver [org.postgresql.Driver] but failed to unregister it when the web application was stopped. To prevent a memory leak, the JDBC Driver has been forcibly unregistered.
Apr 21, 2013 6:15:36 PM org.apache.catalina.loader.WebappClassLoader clearThreadLocalMap
SEVERE: The web application [] created a ThreadLocal with key of type [java.lang.ThreadLocal] (value [java.lang.ThreadLocal@1f5a886]) and a value of type [org.dom4j.DocumentFactory] (value [org.dom4j.DocumentFactory@270af66b]) but failed to remove it when the web application was stopped. This is very likely to create a memory leak.
log4j:ERROR LogMananger.repositorySelector was null likely due to error in class reloading, using NOPLoggerRepository.
Apr 21, 2013 6:15:37 PM org.apache.coyote.http11.Http11Protocol destroy
INFO: Stopping Coyote HTTP/1.1 on http-8090"
____________________________________________________________________________
Below is the atlassian-conlfuence.log:
"2013-04-21 00:52:36,052 INFO [main] [com.atlassian.confluence.lifecycle] contextInitialized Starting Confluence 5.3.1 [build 4528 based on commit hash eaa35c45b124c018e6c8bf70a069c3c2f63fd66d]
2013-04-21 00:52:40,150 INFO [main] [atlassian.plugin.manager.DefaultPluginManager] init Initialising the plugin system
2013-04-21 00:52:48,675 INFO [main] [atlassian.plugin.manager.DefaultPluginManager] init Plugin system started in 0:00:08.519
2013-04-21 00:52:51,292 INFO [main] [com.atlassian.confluence.lifecycle] init Confluence is ready to serve
2013-04-21 17:04:34,006 FATAL [Thread-7] [atlassian.spring.container.SpringContainerContext] getComponent Spring Application context has not been set
2013-04-21 17:04:34,068 WARN [Thread-7] [atlassian.confluence.plugin.PluginFrameworkContextListener] contextDestroyed Failed to shut down plugin system during ServletContext shutdown: Spring Application context has not been set
2013-04-21 17:04:34,069 INFO [Thread-7] [com.atlassian.confluence.lifecycle] contextDestroyed Stopping Confluence
2013-04-21 17:04:34,072 INFO [Thread-7] [atlassian.plugin.manager.DefaultPluginManager] shutdown Shutting down the plugin system
2013-04-21 17:05:21,415 INFO [main] [com.atlassian.confluence.lifecycle] contextInitialized Starting Confluence 5.3.1 [build 4528 based on commit hash eaa35c45b124c018e6c8bf70a069c3c2f63fd66d]
2013-04-21 17:05:31,145 INFO [main] [atlassian.plugin.manager.DefaultPluginManager] init Initialising the plugin system
2013-04-21 17:05:43,573 INFO [main] [atlassian.plugin.manager.DefaultPluginManager] init Plugin system started in 0:00:12.411
2013-04-21 17:05:46,674 INFO [main] [com.atlassian.confluence.lifecycle] init Confluence is ready to serve
2013-04-21 18:12:59,331 FATAL [main] [atlassian.spring.container.SpringContainerContext] getComponent Spring Application context has not been set
2013-04-21 18:12:59,391 WARN [main] [atlassian.confluence.plugin.PluginFrameworkContextListener] contextDestroyed Failed to shut down plugin system during ServletContext shutdown: Spring Application context has not been set
2013-04-21 18:12:59,392 INFO [main] [com.atlassian.confluence.lifecycle] contextDestroyed Stopping Confluence
2013-04-21 18:12:59,401 INFO [main] [atlassian.plugin.manager.DefaultPluginManager] shutdown Shutting down the plugin system
2013-04-21 18:13:14,454 INFO [main] [com.atlassian.confluence.lifecycle] contextInitialized Starting Confluence 5.3.1 [build 4528 based on commit hash eaa35c45b124c018e6c8bf70a069c3c2f63fd66d]
2013-04-21 18:13:18,802 INFO [main] [atlassian.plugin.manager.DefaultPluginManager] init Initialising the plugin system
2013-04-21 18:13:27,524 INFO [main] [atlassian.plugin.manager.DefaultPluginManager] init Plugin system started in 0:00:08.714
2013-04-21 18:13:29,361 INFO [main] [com.atlassian.confluence.lifecycle] init Confluence is ready to serve
2013-04-21 18:15:10,819 INFO [main] [com.atlassian.confluence.lifecycle] contextInitialized Starting Confluence 5.3.1 [build 4528 based on commit hash eaa35c45b124c018e6c8bf70a069c3c2f63fd66d]
2013-04-21 18:15:15,191 INFO [main] [atlassian.plugin.manager.DefaultPluginManager] init Initialising the plugin system
2013-04-21 18:15:23,866 INFO [main] [atlassian.plugin.manager.DefaultPluginManager] init Plugin system started in 0:00:08.665
2013-04-21 18:15:25,693 INFO [main] [com.atlassian.confluence.lifecycle] init Confluence is ready to serve
2013-04-21 18:15:26,803 FATAL [main] [atlassian.spring.container.SpringContainerContext] getComponent Spring Application context has not been set
2013-04-21 18:15:26,856 WARN [main] [atlassian.confluence.plugin.PluginFrameworkContextListener] contextDestroyed Failed to shut down plugin system during ServletContext shutdown: Spring Application context has not been set
2013-04-21 18:15:26,860 INFO [main] [com.atlassian.confluence.lifecycle] contextDestroyed Stopping Confluence
2013-04-21 18:15:26,868 INFO [main] [atlassian.plugin.manager.DefaultPluginManager] shutdown Shutting down the plugin system
2013-04-21 18:15:36,520 FATAL [main] [atlassian.spring.container.SpringContainerContext] getComponent Spring Application context has not been set
2013-04-21 18:15:36,574 WARN [main] [atlassian.confluence.plugin.PluginFrameworkContextListener] contextDestroyed Failed to shut down plugin system during ServletContext shutdown: Spring Application context has not been set
2013-04-21 18:15:36,574 INFO [main] [com.atlassian.confluence.lifecycle] contextDestroyed Stopping Confluence
2013-04-21 18:15:36,578 INFO [main] [atlassian.plugin.manager.DefaultPluginManager] shutdown Shutting down the plugin system
2013-04-21 18:15:46,483 INFO [main] [com.atlassian.confluence.lifecycle] contextInitialized Starting Confluence 5.3.1 [build 4528 based on commit hash eaa35c45b124c018e6c8bf70a069c3c2f63fd66d]
2013-04-21 18:15:50,840 INFO [main] [atlassian.plugin.manager.DefaultPluginManager] init Initialising the plugin system
2013-04-21 18:15:59,385 INFO [main] [atlassian.plugin.manager.DefaultPluginManager] init Plugin system started in 0:00:08.535
2013-04-21 18:16:01,230 INFO [main] [com.atlassian.confluence.lifecycle] init Confluence is ready to serve"
SORRY FOR ALL OF THE LOGS JUST TRYING TO TROUBLESHOOT AS I WAIT FOR ANSWERS.
___________________________________________________________________________
Based on this link: https://confluence.atlassian.com/display/CONFKB/Confluence+Does+Not+Start+Due+to+'Spring+Application+context+has+not+been+set'+in+Linux
i believe my issue was running this as root. I will follow this guide and update the post as to the resolution.