I want to retain the old version as a reference to see if anything missing after upgrade.
Options:
1. Put both on the same server, different directories
Fail! I can't start the old version after shutting down the new version. Maybe due to license issue ?
2. New version on production server, old version on test server
Fail! The same reason as 1.
3. New version on another production server, old intact as status quo
Does this works? Haven't tried it because I'm afraid of the scenario that the old version can't be started due to license issue.
Or is there any recommendated backup strategy?
Thanks.