Hi
I've just upgraded to confluence 4.1 (from 4.0.5) and on start-up the content is reindexed. I can see from confluence log the following pdfbox warning/exception:
2012-01-06 10:08:10,383 WARN [scheduler_Worker-8] [apache.pdfbox.util.PDFStreamEngine] processOperator java.io.IOException: Error: expected hex character and not :32
java.io.IOException: Error: expected hex character and not :32
Googling the error is seems to be related to the bundled version of pdfbox (pdfbox-1.2.1.jar), and has been reported here: https://jira.atlassian.com/browse/CONF-22358
My question is, should i manually upgrade pdfbox-1.2.1.jar (latest stable version is pdfxbox-1.6.0.jar), or is it best to wait for an official atlassian confluence update?
Many thanks.
Gavin.