In my Stash installation I configured tomcat's server.xml and web.xml according to this link so that HTTP is blocked and automatically redirected to HTTPS. Using a self-signed certifcate the stash backup client runs into trouble, output is:
2014-10-10 13:13:36,673 ERROR A backup could not be created. Reason: java.lang.RuntimeException: javax.net.ssl.SSLHandshakeException: java.security.cert.CertificateException: No name matching <our real and existing servername> found
org.apache.wink.client.ClientRuntimeException: java.lang.RuntimeException: javax.net.ssl.SSLHandshakeException: java.security.cert.CertificateException: No name matching <our real and existing servername> found
What I tried:
- localhost and <our real and existing servername>, run as root or the stash user
- added javax.net.ssl.keyStore=/home/atlstash/.keystore to backup-config.properties (location of the keystore containing the self-signed certificate)
- Everything else works as expected after accepting the certificate when entering the site for the very first time
What can I do to get this working?
Is there a way to allow HTTP connections to tomcat from localhost only?
Thanks in advance