Following the LDAP documentation for Confluence 5.3.1 I have configured the LDAP connector.
Works great but does not auto add the user to confluence-users so user is denied access.
Name: LDAP server
Active: true
Type: CONNECTOR
Allowed operations: [CREATE_GROUP, UPDATE_USER_ATTRIBUTE, UPDATE_GROUP_ATTRIBUTE, DELETE_GROUP, UPDATE_GROUP]
Implementation class: com.atlassian.crowd.directory.MicrosoftActiveDirectory
Attributes:
"autoAddGroups": "confluence-users"
Looking for suggestions on where to look for why this does not work as intended.
You have to manually login to Confluence and go into the user settings and manually add the user to confluence-users group, which then grants access.
thanks for any hints!
CTS