Recently we have upgraded to confluence development to latest 5.1.3.
After a day or two the server started throwing "SEVERE: Exception Processing ErrorPage[errorCode=500, location=/500page.jsp]" while I tried restarting confluence, checking the memory usage the solution was to remove the plugin cache directories.
But soon after that the login page came up as garbled and it started throwing "
confluence java.net.SocketException: Too many open files"
which seems to have resolved after I changed the max open file from 1024 to 4096.
My question is what can assure me that this won't be happening when we upgrade Production confluence. And what was the real reason in the first place for the above mentioned errors.
Moinul Rony