When running the Bitbucker Server installer to upgrade an existing instance, it complains if I don't run via sudo (since it then wouldn't be able to install as a service), but if I do, the installer changes the ownership of all the Bitbucket files to root, resulting in the service failing to start as it can't access the files. Am I just running the installer incorrectly?
It also does not update the service/init script to point to the new version. The installer could at least warn that this is a required manual step.