After upgrading from confluence 5.5 (server) to 5.9.2 confluence seem to start up like it should, but trying to reach the web interface i only see:
Error occurred during template rendering: Invocation of method 'getHtml' in class com.atlassian.confluence.plugin.descriptor.web.ConfluenceWebInterfaceManager$ExceptionHandlingWebPanel threw exception java.lang.LinkageError: loader constraint violation: when resolving method "com.atlassian.confluence.util.velocity.VelocityUtils.getRenderedTemplate(Ljava/lang/String;Lorg/apache/velocity/context/Context;)Ljava/lang/String;" the class loader (instance of org/apache/felix/framework/BundleWiringImpl$BundleClassLoaderJava5) of the current class, de/nielsjaeckel/confluence/plugins/universalnavigation/renderer/HtmlListRenderer, and the class loader (instance of org/apache/catalina/loader/WebappClassLoader) for the method's defining class, com/atlassian/confluence/util/velocity/VelocityUtils, have different Class objects for the type org/apache/velocity/context/Context used in the signature at template/includes/macros.vm[line 1451, column 20]. Contact your administrator for assistance.
Among other bugs i noticed that all files were overwritten by root (which the installer demanded), so i have chowned both application directory and installation directory to the right user again, however same message on restart.
The error seems to refer to https://ecosystem.atlassian.net/browse/ATR-42 but i don't see a solution, just that it's fixed. I also attempted reaching the addon's on http://<our.confluence.address>:8090/plugins/servlet/upm#compatibility but this renders the same error screen as above.
I also attempted copying back the old server.xml which contained a few modifications (opening several http/https connectors), but all ports opened report the same error.
Have anyone seen this error before? Thankful for anything that might lead me right.