I just updated our Stash from 3.6.1 to 3.9.1.
Installation works fine.
But, after stopping 3.6 and starting 3.9, i caanot access 3.9 via Browser or git-command; the startup tells me, everything is alright.
root@stash:~# /opt/atlassian/stash/3.9.1/bin/start-stash.sh
To run Stash in the foreground, start the server with start-stash.sh -fg
Starting Atlassian Stash as dedicated user atlstash
No directory, logging in with HOME=/
-su: line 0: cd: /root: Permission denied
-------------------------------------------------------------------------------
Stash is being run with a umask that contains potentially unsafe settings.
The following issues were found with the mask "u=rwx,g=rwx,o=rx" (0002):
- access is allowed to 'others'. It is recommended that 'others' be denied
all access for security reasons.
- write access is allowed to 'group'. It is recommend that 'group' be
denied write access. Read access to a restricted group is recommended
to allow access to the logs.
The recommended umask for Stash is "u=,g=w,o=rwx" (0027) and can be
configured in setenv.sh
-------------------------------------------------------------------------------
Using STASH_HOME: /home/stash_home
Using CATALINA_BASE: /opt/atlassian/stash/3.9.1
Using CATALINA_HOME: /opt/atlassian/stash/3.9.1
Using CATALINA_TMPDIR: /opt/atlassian/stash/3.9.1/temp
Using JRE_HOME: /usr/lib/jvm/java-7-oracle
Using CLASSPATH: /opt/atlassian/stash/3.9.1/bin/stash-bootstrap.jar:/opt/atlassian/stash/3.9.1/bin/bootstrap.jar:/opt/atlassian/stash/3.9.1/bin/tomcat-juli.jar
Using CATALINA_PID: /opt/atlassian/stash/3.9.1/work/catalina.pid
Existing PID file found during start.
Removing/clearing stale PID file.
Tomcat started.
Success! You can now use Stash at the following address:
http://localhost:7990/
If you cannot access Stash at the above location within 3 minutes, or encounter any other issues starting or stopping Atlassian Stash, please see the troubleshooting guide at:
https://confluence.atlassian.com/display/STASHKB/Troubleshooting+Installation
root@stash:~#
But: I still can start the old 3.6.1 Stash - so we can work on, BUT: I still want to work with the newer version, so please help.
Thanks.