After installing Visual Studio on a Windows 2008 server that hosts our JIRA instance we can no longer access JIRA. Chrome displays a generic 404 error - The requested resource () is not available.
In atlassian-jira.log I find:
2012-09-19 12:14:18,237 main ERROR [atlassian.jira.startup.LauncherContextListener] Unable to start JIRA.
com.atlassian.jira.exception.DataAccessException: java.sql.SQLException: Cannot open database "jiradb" requested by the login. The login failed.
I am able to 'manually' log on to the JIRADB database using the login configured in JIRA
Presumably, the VS2010 installation has made some permissions changes to SQLServer logins in the background, but they are not obvious.
Does anyone have a suggestion was to where I should start looking? Any help gratefully received.