Confluence Data Center was sending email for years with Office365
Recently stopped sending
We switched to 9.4.1 with OAuth. Authorize shows "The mail server is now authorized"
Test email fails with
An error has occurred with sending the test email:
com.atlassian.mail.MailException: javax.mail.AuthenticationFailedException: 535 5.7.3 Authentication unsuccessful [YTBP288CA0012.CANP288.PROD.OUTLOOK.COM 2025-05-06T12:28:30.554Z 08DD8C2B51A3DB4F]
MFA disabled for this user
We did try to add
CATALINA_OPTS="-Dmail.smtp.starttls.enable=true -Dmail.smtp.ssl.protocols=TLSv1.2 ${CATALINA_OPTS}"
Confluence Mail Server Setup issue due to TLS | Confluence | Atlassian Support