Guys
let me re-phrase my issue i posted last night.
Last night I tried to access jira using default ports i.e. 80 and 443 (by amending the server.xml port numbers) then accessing it through http://localhost:80 and https:localhost:443. But I received apache 404 error page. However, if i used any other random port it worked yesterday.
Today morning i uninstalled jira and did afresh installation and it worked. jira could then be accessed through all ports inc 80 and 443.
This now confirms that it was nothing to do with firewalls.
Any idea what may have been the root cause of the issue?
PS: I have a standalone installation on windows server.
Rahul