Dear Community,
After upgrading our Confluence (Data Center) from version 7.19.X to 8.5.11 the publishToConfluence task in docToolchain fails with the following error message:
Execution failed for task ':publishToConfluence'. > something went wrong - request failed (response: 500 handshakefailed, reason: <none>)
We are using the following docker version of doctoolchain v3.4.1: https://hub.docker.com/layers/doctoolchain/doctoolchain/v3.4.1/images/sha256-a6f845173cba0623fac04dc425d989924158dd9fef56a249a3e4be385f5f997d?context=exploreThe container is running on a RHEL8 Jenkins Slave.
Has anyone encountered a similar issue or found a solution that enables docToolchain compatibility with Confluence 8.5?Are there specific requirements for connecting external tools to Confluence 8.5 that we should consider?
Thank you in advance for any insights!
Kind regardsChris
Hi @Chris K
I'd go thru the docToolchainConfig.groovy file and make sure it's not an API v1 vs v2 issue and that all other settings match what the new version of Confluence is expecting.
Hi @Shawn Doyle - ReleaseTEAM
Thank you for bringing this up. Based on my understanding, Confluence’s API v2 is currently only available for Cloud instances, while Confluence Data Center relies solely on API v1.
After reviewing the release notes for Confluence 8.5 and API documentation, we couldn’t find any new requirements related to API usage that might affect our current configuration, thats why we are a little bit lost right now
@Chris K
I'm sorry. I completely missed that you labeled this as a 'server' platform, even though you say Data Center in your question.
I would still go through the Groovy file to make sure no settings needed tweaking after the upgrade of Confluence.
It looks like you're new here. Sign in or register to get started.