I post this here, since other people might find the info useful:
Can someone at Atlassian please confirm or deny the following as being a bug?
In JIRA 5.1, setting Outgoing mail to be delivered via an MS Exchange server that only permits NTLM authentication, sending fails with Authentication Failed, even with correct credentials. Setting the startup option pertaining to auth domain has no effect.
Replacing atlassian-jira/WEB-INF/lib/mail-1.4.6.jar with version 1.4.1 resolves the problem.
It seems to me, that either there is a bug in JavaMail 1.4.6 *or* there is a bug in JIRA 5.1 regarding its use of JavaMail 1.4.6 - it being possible that something changed between 1.4.1 and 1.4.6 regarding how to make use of the library.
Best regards,
Sune Mølgaard