Install was a migration from a windows server. Pointed installer to a data folder containing the backup from windows. After install finished the service won't start. RHEL 8.
/opt/atlassian/bitbucket/7.21.23/jre/bin/java: error while loading shared libraries: libjli.so: cannot open shared object file: No such file or directory
I did a fresh install with no old data and service starts right up. I then copied over the old data folder and don't get the libjli.so error but do get this.
runuser: warning: cannot change directory to /opt/bitbucket/data: No such file or directory
This path is nowhere in any config file. Wasn't used when I installed, and definitely isn't from windows. Correct actual path is /opt/atlassian/bitbucket/data.