We have a single machine - single IP running multiple instances (JIRA / Confluence ...)
We have SSL enabled on all instances; This works fine when accessing the service through a browser (using SNI). When using applicaiton links to link a confluence page from wiki.domain1.com to jira.domain1.com
things fail with
javax.net.ssl.SSLHandshakeException: sun.security.validator.ValidatorException: PKIX path building failed: sun.security.provider.certpath.SunCertPathBuilderException
This is because apache is returning the certificate of jira.domain2.com
Is SNI supported by the application links, and if not does someone knows how to fix this issue ?
Francis