While setting up Outgoing Authentication for the Amazon Security Hub integration, I encountered an issue when selecting the region. Although "ca_central_1" is available in the drop down menu, saving it results in an error indicating that the region is invalid and should be "ca-central-1" (with dashes instead of underscores). Unfortunately, the drop down menu doesn't allow for manual changes, leaving me unable to correct the region format.
