Hello, i use currently JIRA in version 6.3.6 and i use it with SSL via an Apache-Proxy.
Here is what happens if i try to connect with another application like confluence:
javax.net.ssl.SSLHandshakeException: sun.security.validator.ValidatorException: PKIX path building failed: sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested target
I imported the certificates of every domain and the root ca certificate:
srv1:/opt/atlassian# keytool -list -keystore $JAVA_HOME/jre/lib/security/cacerts | grep domain.net
Enter keystore password: changeit
confluence.domain.net, Sep 28, 2014, trustedCertEntry,
stash.domain.net, Sep 28, 2014, trustedCertEntry,
bamboo.domain.net, Sep 28, 2014, trustedCertEntry,
jira.domain.net, Sep 28, 2014, trustedCertEntry,
srv1:/opt/atlassian# keytool -list -keystore $JAVA_HOME/jre/lib/security/cacerts | grep startcom
Enter keystore password: changeit
debian:startcom_certification_authority_g2.pem, Aug 6, 2014, trustedCertEntry,
startcom.ca.sub.class4, Sep 28, 2014, trustedCertEntry,
startcom.ca.sub.class3, Sep 28, 2014, trustedCertEntry,
startcom.ca.sub.class2, Sep 28, 2014, trustedCertEntry,
startcom.ca.sub.class1, Sep 28, 2014, trustedCertEntry,
startcom.ca, Sep 28, 2014, trustedCertEntry,
debian:startcom_certification_authority.pem, Aug 6, 2014, trustedCertEntry,
I googled this problem but everyone say only: Import the certificates to the keystore, but i already did it and the problem still exists.
What can be the problem?