Hi all,
Our AD users lost access to JIRA. It happened just abruptly.
Because we a had a working connection JIRA <-> AD.
Long ago we tuned such integration through our home made certificate using "./keytool -import" and it worked.
Yesterday I found out that "ldap.secure" parameter set to "true" I changed it to "false", restarted JIRA but still no access for AD users.
Log:
Caused by: org.springframework.transaction.CannotCreateTransactionException: Could not create DirContext instance for transaction; nested exception is org.springframework.ldap.CommunicationException: <server name>; nested exception is javax.naming.CommunicationException: <server name>:636 [Root exception is javax.net.ssl.SSLHandshakeException: sun.security.validator.ValidatorException: PKIX path building failed: sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested target]
So can SSL certificate expire?
And what else can be done to fix it?
Thank you.