hi every one
i use nginx for revers proxy with the help of the link belowhttps://confluence.atlassian.com/jirakb/configure-jira-server-to-run-behind-a-nginx-reverse-proxy-426115340.htmlbut my gadget show __MSG_gadget nameI will be grateful if you can guide me
nginx.conf:
server { listen 443 ssl; server_name jira.[name].com; ssl_certificate /etc/nginx/certs/jira.[name].com.pem; ssl_certificate_key /etc/nginx/certs/jira.[name].com.key; client_max_body_size 134217728; access_log "/etc/nginx/Logs/1.log"; error_log "/etc/nginx/Logs/2.log"; root "<local_httpdocs>"; #extension letsencrypt begin location ^~ /.well-known/acme-challenge/ { root <local_htdocs>; types { } default_type text/plain; satisfy any; auth_basic off; allow all; location ~ ^/\.well-known/acme-challenge.*/\. { deny all; } } #extension letsencrypt end #extension sslit begin #extension sslit end location / { proxy_pass https://localhost:8080/; proxy_hide_header upgrade; proxy_set_header Host $host; proxy_set_header X-Real-IP $remote_addr; proxy_set_header X-Forwarded-For $proxy_add_x_forwarded_for; access_log off; } proxy_connect_timeout 180s;proxy_send_timeout 180s;proxy_read_timeout 180s;fastcgi_send_timeout 180s;fastcgi_read_timeout 180s;}}server.xml:<Connector port="8080"relaxedPathChars="[]|"relaxedQueryChars="[]|{}^\`"<>"maxThreads="150"minSpareThreads="25"connectionTimeout="20000"enableLookups="false"maxHttpHeaderSize="8192"protocol="HTTP/1.1"useBodyEncodingForURI="true"redirectPort="8443"acceptCount="100"disableUploadTimeout="true"proxyName="jira.[name].com"proxyPort="443"scheme="https"secure="true"/>
server { listen 443 ssl; server_name jira.[name].com; ssl_certificate /etc/nginx/certs/jira.[name].com.pem; ssl_certificate_key /etc/nginx/certs/jira.[name].com.key; client_max_body_size 134217728; access_log "/etc/nginx/Logs/1.log"; error_log "/etc/nginx/Logs/2.log"; root "<local_httpdocs>"; #extension letsencrypt begin location ^~ /.well-known/acme-challenge/ { root <local_htdocs>; types { } default_type text/plain; satisfy any; auth_basic off; allow all; location ~ ^/\.well-known/acme-challenge.*/\. { deny all; } } #extension letsencrypt end #extension sslit begin #extension sslit end location / { proxy_pass https://localhost:8080/; proxy_hide_header upgrade; proxy_set_header Host $host; proxy_set_header X-Real-IP $remote_addr; proxy_set_header X-Forwarded-For $proxy_add_x_forwarded_for; access_log off; } proxy_connect_timeout 180s;proxy_send_timeout 180s;proxy_read_timeout 180s;fastcgi_send_timeout 180s;fastcgi_read_timeout 180s;}}
server.xml:
<Connector port="8080"relaxedPathChars="[]|"relaxedQueryChars="[]|{}^\`"<>"maxThreads="150"minSpareThreads="25"connectionTimeout="20000"enableLookups="false"maxHttpHeaderSize="8192"protocol="HTTP/1.1"useBodyEncodingForURI="true"redirectPort="8443"acceptCount="100"disableUploadTimeout="true"proxyName="jira.[name].com"proxyPort="443"scheme="https"secure="true"/>
There's not really a single point to look into with this one, I've seen this couple times, some years back, I think it was solved a bit differently each time.
Take a look here: https://confluence.atlassian.com/jirakb/fix-gadget-titles-showing-as-__msg_gadget-in-jira-server-813697086.html
I'd suggest going through the list and checking things one by one, eventually something off that list should do it.
Hi Sina,
That error message is mostly given when a Jira system can not reach itself over your network.
If you were to log into your Jira server and run something like "wget <base-url of your Jira>" it will return an error. This is a useful test actually, because it will give you the underlying error.
The three usual culprits are:
It looks like you're new here. Sign in or register to get started.