I have tested it on ubuntu 11 and it works, but on suse there is no conlfuence user. I looked in the passwd and shadow.
The error message occurs when I execute the start-confluence.sh:
To run Confluence in the foreground, start the server with start-confluence.sh -fg
executing using dedicated user: confluence
su: user confluence does not exist
I'm on openSUSE 11.2 64 bit