Can't access confluence URL after upgrade. Confluence process are present after upgrade. we are running Ubuntu 16.04.
Hi @Mike Wessels and welcome to the community.
Are you getting any error when you try to access Confluence after the upgrade? Can you share if there is any error message in either the <confluence-install>/logs/catalina.out or in the <confluence-data-dir>/logs/atlassian-confluence.log?
Thanks for you Response.
I am finding errors in both install4J/installation.log, catalina.out. the installation log shows 1 error:
:[ERROR] com.install4j.runtime.beans.actions.files.CopyFileAction [ID 65555]: Execute action not successful after 1 ms
catalina out shows many errors. Here are some things that I find by grepping the log for error:
/logs/catalina.out:Exception in thread "I/O dispatcher 19" java.lang.OutOfMemoryError: Java heap space./logs/catalina.out:Exception in thread "I/O dispatcher 15" java.lang.OutOfMemoryError: Java heap space./logs/catalina.out:Exception in thread "I/O dispatcher 7" java.lang.OutOfMemoryError: Java heap space./logs/catalina.out:Exception in thread "I/O dispatcher 11" java.lang.OutOfMemoryError: Java heap space./logs/catalina.out:Exception in thread "I/O dispatcher 6" java.lang.OutOfMemoryError: Java heap space./logs/catalina.out:Exception in thread "I/O dispatcher 9" java.lang.OutOfMemoryError: Java heap space./logs/catalina.out:Exception in thread "Connection evictor" java.lang.OutOfMemoryError: Java heap space./logs/catalina.out:ERROR: org.apache.felix.framework.cache.BundleArchive: Unable to cache bundle info - java.io.FileNotFoundException: /var/atlassian/application-data/confluence/plugins-osgi-cache/felix/felix-cache/bundle34/bundle.info (No such file or directory)./logs/catalina.out:ERROR: Bundle com.atlassian.confluence.image.effects.ImageEffectsPlugin [34] Error writing persistent state to bundle archive. (java.io.FileNotFoundException: /var/atlassian/application-data/confluence/plugins-osgi-cache/felix/felix-cache/bundle34/bundle.info (No such file or directory))./logs/catalina.out: at com.atlassian.plugin.manager.DefaultPluginManager.broadcastIgnoreError(DefaultPluginManager.java:2129)./logs/catalina.out:ERROR: org.apache.felix.framework.cache.BundleArchive: Unable to cache bundle info - java.io.FileNotFoundException: /var/atlassian/application-data/confluence/plugins-osgi-cache/felix/felix-cache/bundle34/bundle.info (No such file or directory)./logs/catalina.out:ERROR: Bundle com.atlassian.confluence.image.effects.ImageEffectsPlugin [34] Error writing last modification time to bundle archive. (java.io.FileNotFoundException: /var/atlassian/application-data/confluence/plugins-osgi-cache/felix/felix-cache/bundle34/bundle.info (No such file or directory))./logs/catalina.out: at com.atlassian.plugin.manager.DefaultPluginManager.broadcastIgnoreError(DefaultPluginManager.java:2129)./logs/catalina.out:ERROR: org.apache.felix.framework.cache.BundleArchive: Unable to cache bundle info - java.io.FileNotFoundException: /var/atlassian/application-data/confluence/plugins-osgi-cache/felix/felix-cache/bundle248/bundle.info (No such file or directory)
Hi Mike, it seems your not giving enough heap for Confluence to upgrade.
./logs/catalina.out:Exception in thread "I/O dispatcher 7" java.lang.OutOfMemoryError: Java heap space
Can you check inside the <installation directory>/bin/setenv.sh, and locate the -Xms in the CATALINA_OPTS session.
See how much heap you have given to Confluence and try to increase that a bit. I'd recommend at lease 2GB.
https://confluence.atlassian.com/confkb/how-to-fix-out-of-memory-errors-by-increasing-available-memory-154071.html
It might also be a good thing to disable the recovery file generation, provided that you have an external backup.
https://confluence.atlassian.com/confkb/how-to-disable-upgrade-recovery-file-generation-in-confluence-1047534410.html
Thanks for your help! I increased heap to 2G as you suggested. Shut down and restarted confluence. The logs looks cleaner but I can not connect to the confluence URL. Here is the output of catalina.out from where the restart occurred. The last message scrolls constantly in the log.
16-Jan-2024 10:32:20.065 WARNING [main] org.apache.tomcat.util.digester.SetPropertiesRule.begin [SetPropertiesRule]{Server} Setting property 'debug' to '0' did not find a matching property.16-Jan-2024 10:32:20.619 WARNING [main] org.apache.catalina.startup.SetAllPropertiesRule.begin [SetAllPropertiesRule]{Server/Service/Connector} Setting property 'debug' to '0' did not find a matching property.16-Jan-2024 10:32:23.436 WARNING [main] org.apache.tomcat.util.digester.SetPropertiesRule.begin [SetPropertiesRule]{Server/Service/Engine} Setting property 'debug' to '0' did not find a matching property.16-Jan-2024 10:32:23.439 WARNING [main] org.apache.tomcat.util.digester.SetPropertiesRule.begin [SetPropertiesRule]{Server/Service/Engine/Host} Setting property 'debug' to '0' did not find a matching property.16-Jan-2024 10:32:23.643 WARNING [main] org.apache.tomcat.util.digester.SetPropertiesRule.begin [SetPropertiesRule]{Server/Service/Engine/Host/Context} Setting property 'debug' to '0' did not find a matching property.16-Jan-2024 10:32:23.844 WARNING [main] org.apache.tomcat.util.digester.SetPropertiesRule.begin [SetPropertiesRule]{Server/Service/Engine/Host/Context} Setting property 'debug' to '0' did not find a matching property.16-Jan-2024 10:32:25.718 INFO [main] org.apache.coyote.AbstractProtocol.init Initializing ProtocolHandler ["http-nio-8090"]16-Jan-2024 10:32:26.384 INFO [main] org.apache.tomcat.util.net.NioSelectorPool.getSharedSelector Using a shared selector for servlet write/read16-Jan-2024 10:32:26.500 INFO [main] org.apache.catalina.startup.Catalina.load Initialization processed in 7043 ms16-Jan-2024 10:32:26.664 INFO [main] org.apache.catalina.core.StandardService.startInternal Starting service [Tomcat-Standalone]16-Jan-2024 10:32:26.664 INFO [main] org.apache.catalina.core.StandardEngine.startInternal Starting Servlet Engine: Apache Tomcat/9.0.1216-Jan-2024 10:32:33.081 INFO [localhost-startStop-2] org.apache.jasper.servlet.TldScanner.scanJars At least one JAR was scanned for TLDs yet contained no TLDs. Enable debug logging for this logger for a complete list of JARs that were scanned but no TLDs were found in them. Skipping unneeded JARs during scanning can improve startup time and JSP compilation time.16-Jan-2024 10:32:33.144 INFO [localhost-startStop-2] org.apache.catalina.core.ApplicationContext.log Spring WebApplicationInitializers detected on classpath: [com.atlassian.synchrony.proxy.SynchronyDispatcherServletInitializer@7f8ffdeb]16-Jan-2024 10:32:33.725 WARNING [localhost-startStop-2] org.apache.catalina.util.SessionIdGeneratorBase.createSecureRandom Creation of SecureRandom instance for session ID generation using [SHA1PRNG] took [248] milliseconds.16-Jan-2024 10:32:33.825 INFO [localhost-startStop-2] org.apache.catalina.core.ApplicationContext.log Initializing Spring FrameworkServlet 'dispatcher'16-Jan-2024 10:32:33.825 INFO [localhost-startStop-2] org.springframework.web.servlet.DispatcherServlet.initServletBean FrameworkServlet 'dispatcher': initialization started16-Jan-2024 10:32:33.827 INFO [localhost-startStop-2] org.springframework.web.context.support.AnnotationConfigWebApplicationContext.prepareRefresh Refreshing WebApplicationContext for namespace 'dispatcher-servlet': startup date [Tue Jan 16 10:32:33 CST 2024]; root of context hierarchy16-Jan-2024 10:32:33.900 INFO [localhost-startStop-2] org.springframework.web.context.support.AnnotationConfigWebApplicationContext.loadBeanDefinitions Registering annotated classes: [class com.atlassian.synchrony.proxy.websocket.WebSocketConfig,class com.atlassian.synchrony.proxy.web.SynchronyWebMvcConfig]16-Jan-2024 10:32:34.499 INFO [localhost-startStop-2] org.springframework.scheduling.concurrent.ThreadPoolTaskScheduler.initialize Initializing ExecutorService 'defaultSockJsTaskScheduler'16-Jan-2024 10:32:34.647 INFO [localhost-startStop-2] org.springframework.web.socket.server.support.WebSocketHandlerMapping.registerHandler Mapped URL path [/v1/bayeux-sync1] onto handler of type [class org.springframework.web.socket.server.support.WebSocketHttpRequestHandler]16-Jan-2024 10:32:34.993 INFO [localhost-startStop-2] org.springframework.web.servlet.mvc.method.annotation.RequestMappingHandlerMapping.register Mapped "{[/healthcheck]}" onto public com.atlassian.synchrony.proxy.web.HealthCheckResult com.atlassian.synchrony.proxy.web.SynchronyProxyRestController.getSynchronyProxyInfo()16-Jan-2024 10:32:34.993 INFO [localhost-startStop-2] org.springframework.web.servlet.mvc.method.annotation.RequestMappingHandlerMapping.register Mapped "{[/reload],methods=[PUT]}" onto public org.springframework.http.ResponseEntity com.atlassian.synchrony.proxy.web.SynchronyProxyRestController.reloadConfiguration(com.atlassian.synchrony.proxy.web.SynchronyProxyConfigPayload)16-Jan-2024 10:32:35.011 INFO [localhost-startStop-2] org.springframework.web.servlet.handler.SimpleUrlHandlerMapping.registerHandler Mapped URL path [/**] onto handler of type [class org.springframework.web.servlet.resource.DefaultServletHttpRequestHandler]16-Jan-2024 10:32:35.067 INFO [localhost-startStop-2] org.springframework.web.servlet.mvc.method.annotation.RequestMappingHandlerAdapter.initControllerAdviceCache Looking for @ControllerAdvice: WebApplicationContext for namespace 'dispatcher-servlet': startup date [Tue Jan 16 10:32:33 CST 2024]; root of context hierarchy16-Jan-2024 10:32:35.111 INFO [localhost-startStop-2] org.springframework.context.support.DefaultLifecycleProcessor.start Starting beans in phase 214748364716-Jan-2024 10:32:35.122 INFO [localhost-startStop-2] org.springframework.web.servlet.DispatcherServlet.initServletBean FrameworkServlet 'dispatcher': initialization completed in 1297 ms2024-01-16 10:32:35,395 INFO [localhost-startStop-1] [com.atlassian.confluence.lifecycle] contextInitialized Starting Confluence 6.15.1 [build 8100 based on commit hash 655541fd8de32cde09f1d3f09341851d946007a5] - synchrony version 2.1.0-master-9d112c9dTue Jan 16 10:33:15 CST 2024 WARN: Establishing SSL connection without server's identity verification is not recommended. According to MySQL 5.5.45+, 5.6.26+ and 5.7.6+ requirements SSL connection must be established by default if explicit option isn't set. For compliance with existing applications not using SSL the verifyServerCertificate property is set to 'false'. You need either to explicitly disable SSL by setting useSSL=false, or set useSSL=true and provide truststore for server certificate verification.
It looks like you're new here. Sign in or register to get started.