Confluence server version in Linux has been updated to 5.1 to 5.10.9
(5.10.9 so that migration to cloud could be done, but not higher because license doesn't allow it)
Page links have stopped working.

atlassian-confluence.log
2023-11-28 18:31:55,797 ERROR [http-nio-8980-exec-1] [[Standalone].[localhost].[/].[action]] log Servlet.service() for servlet [action] in context with path [] threw exception [Servlet execution threw an exception] with root cause
java.lang.NoSuchMethodError: com.atlassian.confluence.content.render.xhtml.Marshaller.marshal(Ljava/lang/Object;Lcom/atlassian/confluence/content/render/xhtml/ConversionContext;)Ljava/lang/String;
In Confluence start:
Starting confluence
If you encounter issues starting up Confluence, please see the Installation guide at http://confluence.atlassian.com/display/DOC/Confluence+Installation+Guide
Server startup logs are located in /opt/confluence/confluence-3.5.3-std/logs/catalina.out
Using CATALINA_BASE: /opt/confluence/confluence-3.5.3-std
Using CATALINA_HOME: /opt/confluence/confluence-3.5.3-std
Using CATALINA_TMPDIR: /opt/confluence/confluence-3.5.3-std/temp
Using JRE_HOME: /opt/java_atlassian
Using CLASSPATH: /opt/confluence/confluence-3.5.3-std/bin/bootstrap.jar:/opt/confluence/confluence-3.5.3-std/bin/tomcat-juli.jar
Using CATALINA_PID: /opt/confluence/confluence-3.5.3-std/work/catalina.pid
Existing PID file found during start.
Removing/clearing stale PID file.
Tomcat started.
There's directory "confluence-3.5.3-std" because Confluence has already once (many years ago) been updated from 3.5.3 to 5.1. There hasn't been problems with version 5.1, however.
Method com.atlassian.confluence.content.render.xhtml.Marshaller.marshal is found from
/opt/confluence/confluence-3.5.3-std/confluence/WEB-INF/lib/confluence-5.10.9.jar
Java version:
lrwxrwxrwx 1 root root 17 Nov 28 12:59 java_atlassian -> /opt/jdk1.8.0_351