Our company bought the atlassian-confluence-7.18.1 software and hosted it for round about 1.5 years on a local server.
All of a sudden confluence would not work any more. Our Dev-Ops coworker found out that the mysql driver that was used would not work anymore and he needed to update the driver that has to be found in /confluence/WEB-INF/lib.
The problem is that he only found out by reinstalling the very same version of the confluence binaries. But now we have some serious problems.
Our coworker created a backup.sql dump file to restore the old data after installing confluence again.
But confluence responds with an error saying that the database was used by another confluence and it wont allow to use this particular database.
How can we restore our confluence data? The sql dumps are our only backup data available.