Hi,
after upgrading Confluence DataCenter from 7.19 to 8.5 running with Windows Server 2019 64bit we experience the following problems :
- the Confluence-Windowsservice will not stop normally
- we get http500 errors on one node of the Confluence-Cluster
The following lines appear ..
ERROR [https-jsse-nio2-8443-exec-22] [ContainerBase.[Standalone].[localhost].[/]] log Unhandled exception occurred whilst decorating page
-- url: / | userName: xxxxxxx | traceId: f37bc8698694e3f9
java.lang.RuntimeException: javax.servlet.ServletException: org.apache.velocity.exception.VelocityException: ASTIdentifier() : exception invoking method for identifier 'rawOffset' in class sun.util.calendar.ZoneInfo
Caused by: javax.servlet.ServletException: org.apache.velocity.exception.VelocityException: ASTIdentifier() : exception invoking method for identifier 'rawOffset' in class sun.util.calendar.ZoneInfo
Caused by: org.apache.velocity.exception.VelocityException: ASTIdentifier() : exception invoking method for identifier 'rawOffset' in class sun.util.calendar.ZoneInfo
Caused by: java.lang.IllegalAccessException: class org.apache.velocity.runtime.parser.node.PropertyExecutor cannot access class sun.util.calendar.ZoneInfo (in module java.base) because module java.base does not export sun.util.calendar to unnamed module
@65ea0089
2023-09-01 09:36:15,123 ERROR [https-jsse-nio2-8443-exec-22] [[Standalone].[localhost].[/].[default]] log Servlet.service() for servlet [default] in context with path [] threw exception
java.lang.RuntimeException: javax.servlet.ServletException: org.apache.velocity.exception.VelocityException: ASTIdentifier() : exception invoking method for identifier 'rawOffset' in class sun.util.calendar.ZoneInfo
Caused by: javax.servlet.ServletException: org.apache.velocity.exception.VelocityException: ASTIdentifier() : exception invoking method for identifier 'rawOffset' in class sun.util.calendar.ZoneInfo
Caused by: org.apache.velocity.exception.VelocityException: ASTIdentifier() : exception invoking method for identifier 'rawOffset' in class sun.util.calendar.ZoneInfo
2023-09-01 09:28:32,515 ERROR [Catalina-utility-2] [atlassian.plugin.parsers.XmlDescriptorParser] createModuleDescriptor There were problems loading the module 'job'. The module and its plugin have been disabled.
2023-09-01 09:28:32,515 ERROR [Catalina-utility-2] [atlassian.plugin.parsers.XmlDescriptorParser] createModuleDescriptor There was a problem loading the descriptor for module 'job' in plugin 'Confluence JIRA Metadata Plugin'.\n Job module descriptors are no longer supported. Use JobConfig modules instead.
Any suggestions?
Kind regards
Tim
Update:
With help by Atlassian I solved the problem :
Add the following to your setenv.bat :
set CATALINA_OPTS<span>=</span><span>"--add-exports java.naming/com.sun.jndi.ldap=ALL-UNNAMED ${CATALINA_OPTS}"<br></span>
Add the following to your JAVA-Properties:
--add-opens=java.base/sun.util.calendar=ALL-UNNAMED