Hi There,
My jira software plugin is already running on 2990 port now, when i try to to run confluence plugin using atlas-run it is giving me following error, i have tried by changing server, ajp ports in server.xml file but it was not worked please suggest solution for this.
[INFO] [2.ContainerStartMojo] Resolved container artifact org.codehaus.cargo:cargo-core-container-tomcat:jar:1.6.10 for container tomcat8x
[INFO] [talledLocalContainer] Tomcat 8.x starting...
[INFO] [stalledLocalDeployer] Deploying [C:\React\upraise.confluence.server\target\confluence\confluence.war] to [C:\React\upraise.confluence.server\target\container\tomcat8x\cargo-confluence-home\webapps]...
[WARNING] [talledLocalContainer] ERROR: transport error 202: bind failed: Address already in use
[WARNING] [talledLocalContainer] ERROR: JDWP Transport dt_socket failed to initialize, TRANSPORT_INIT(510)
[WARNING] [talledLocalContainer] JDWP exit error AGENT_ERROR_TRANSPORT_INIT(197): No transports initialized [debugInit.c:750]
[INFO] [yer.DeployerWatchdog] Deployable [http://localhost:1990/cargocpc/index.html] failed to finish deploying within the timeout period [600000]. The Deployable state is thus unknown.
[WARNING] [talledLocalContainer] org.codehaus.cargo.container.ContainerException: Deployable [http://localhost:1990/cargocpc/index.html] failed to finish deploying within the timeout period [600000]. The Deployable state is thus unknown.
[ERROR] Starting container [org.codehaus.cargo.container.tomcat.Tomcat8xInstalledLocalContainer@1e5e0e75] failed, now stopping container
[INFO] [talledLocalContainer] Tomcat 8.x is stopping...
[WARNING] [talledLocalContainer] ERROR: transport error 202: bind failed: Address already in use
[WARNING] [talledLocalContainer] ERROR: JDWP Transport dt_socket failed to initialize, TRANSPORT_INIT(510)
[WARNING] [talledLocalContainer] JDWP exit error AGENT_ERROR_TRANSPORT_INIT(197): No transports initialized [debugInit.c:750]
[INFO] [talledLocalContainer] Tomcat 8.x is stopped
[INFO] ------------------------------------------------------------------------
[INFO] BUILD FAILURE
[INFO] ------------------------------------------------------------------------
[INFO] Total time: 11:44 min
[INFO] Finished at: 2023-08-26T08:47:06+05:30
[INFO] ------------------------------------------------------------------------
[ERROR] Failed to execute goal com.atlassian.maven.plugins:amps-dispatcher-maven-plugin:8.1.2:debug (default-cli) on project upraise.confluence.server: Cannot start container [org.codehaus.cargo.container.tomcat.Tomcat8xInstalledLocalContainer@1e5e0e75]: Deployable [http://localhost:1990/cargocpc/index.html] failed to finish deploying within the timeout period [600000]. The Deployable state is thus unknown. -> [Help 1]
[ERROR]
[ERROR] To see the full stack trace of the errors, re-run Maven with the -e switch.
[ERROR] Re-run Maven using the -X switch to enable full debug logging.
[ERROR]
[ERROR] For more information about the errors and possible solutions, please read the following articles:
[ERROR] [Help 1] http://cwiki.apache.org/confluence/display/MAVEN/MojoExecutionException