I created a few dashboards and shared them with my colleagues, but they cannot access them. When they click on the link, they get error messages. In some gadget, they get the message, "The filter configured for this gadget could not be retrieved. Please verify it is still valid on the issue navigator" and in other gadget, they get " There are problems with the current configuration for this gadget. The errors below may have been caused by the deletion of entities required by the gadget or by changes to your permissions"
Please advise how I can enable them to access.