Getting this error after upgrading Jira 9.6 to 9.8.1. The issue occurs when trying to assign a support ticket to either myself via a workflow or manually assigning as an admin.
"org.ofbiz.core.entity.GenericEntityException: while inserting: [GenericEntity:ChangeGroup][issue,17817][author,JIRAUSER10000][created,2023-05-29 09:07:50.244][id,32313] (SQL Exception while executing the following:INSERT INTO dbo.changegroup (ID, issueid, AUTHOR, CREATED) VALUES (?, ?, ?, ?) (Violation of PRIMARY KEY constraint 'PK_changegroup'. Cannot insert duplicate key in object 'dbo.changegroup'. The duplicate key value is (32313).))
It seems that you have tried to perform an illegal workflow operation.
If you think you shouldn't get this message, please contact your Jira administrators."
I have run the integrity checker which found no issues.
The database version is 14.00.3460 and it's using a separate SQL server for its database. I am not familiar with editing SQL so I am hoping there is a solution which doesn't require this. The error occurs with multiple assignees.
There are also issues creating new tickets; the is a notification that pops up saying one or more fields have not been given values but the ticket gets created nevertheless.
Since restoring both Jira and its SQL server from backup, new tickets have this error when being created:
"
Error
Your request could not be created. Please check the fields have been correctly filled in. We can't create this issue for you right now, it could be due to unsupported content you've entered into one or more of the issue fields. If this situation persists, contact your administrator as they'll be able to access more specific information in the log file."