When I got to upload a file into Confl. I am presented with an error: "You must first lock the attachment Test1_rehnuba.csv before it can be edited." and I am unable to upload any files.How do I solve this issue?
Adam
@[deleted]Welcome to the Atlassian community
Are you trying to upload a file that you downloaded and edited? This error is usually caused when you are uploading a file that already exists on the page and you have an app called lockpoint installed. A quick work around it to rename the file and upload it again. Or you will need to find the file on the page, usually easiest way is to look at the page attachments and ensure that it is locked so you can upload a new version on it.
Adam,
It sounds like you have our Cenote Lockpoint app installed.
Lockpoint is used to prevent attachments from being accidentally overwritten with conflicting edits. To make this happen, it works in one of two modes:
Standard mode (what you are currently using)
Before you can upload a new version of an existing attachment, the attachment must be locked first. To lock an attachment, you can add the Attachments macro to the page, find the attachment on it, click to expand, then lock the attachment. Alternatively, you can also visit the page in question, click "..." and then "Attachments", and then use the "Lock" link next to your attachment. When you are done editing the attachment, you should also unlock it using same method as you did to lock it. This mode is the safest, but it does take some effort to update attachments (especially if you are sure that no one else is editing them).
Smart Locking (which can be enabled by your administrator)
Any attachment can be uploaded (even if it already exists), unless the attachment is already locked by someone else. This allows you to quickly update existing documents without locking.
If you are interested in using Smart Locking, you should get in touch with your system administrator to see if that option is something that would work for the rest of your organization.
Additionally, Lockpoint can be enabled or disabled on a space-by-space basis, if it happens to be needed for certain business processes but not others. This is also something you could discuss with your system administrator.
I hope this helps!
With best regards,
Scott @ Cenote
Thank you. I changed the name of the file and it uploaded successfully. Problem solved.
It looks like you're new here. Sign in or register to get started.