Hello,
I've just upgraded my Jira from 4.4.4 to 5.1.5.
I'm seeing an error in the logfile for Incremental Synchronisation of the Remote Crowd Directory (2.4).
This error did'nt exist in 4.4.4.
How can I resolve this (fixing the error or disabling incremental sync) ?
This is an extract of my logfile :
(The full synchro is ok).
2012-10-08 17:56:30,328 QuartzWorker-1 INFO ServiceRunner atlassian.crowd.directory.DbCachingRemoteDirectory synchronisation for directory 2 starting
2012-10-08 17:56:30,406 QuartzWorker-1 WARN ServiceRunner directory.ldap.cache.EventTokenChangedCacheRefresher Incremental synchronisation is not available. Falling back to full synchronisation
com.atlassian.crowd.event.IncrementalSynchronisationNotAvailableException
at com.atlassian.crowd.integration.rest.service.RestCrowdClient.getCurrentEventToken(RestCrowdClient.java:952)
at com.atlassian.crowd.directory.RemoteCrowdDirectory.getCurrentEventToken(RemoteCrowdDirectory.java:651)
at com.atlassian.crowd.directory.ldap.cache.EventTokenChangedCacheRefresher.synchroniseAll(EventTokenChangedCacheRefresher.java:45)
at com.atlassian.crowd.directory.DbCachingRemoteDirectory.synchroniseCache(DbCachingRemoteDirectory.java:619)
at com.atlassian.crowd.manager.directory.DirectorySynchroniserImpl.synchronise(DirectorySynchroniserImpl.java:63)
at com.atlassian.crowd.directory.DbCachingDirectoryPoller.pollChanges(DbCachingDirectoryPoller.java:50)
at com.atlassian.crowd.manager.directory.monitor.poller.DirectoryPollerJob.execute(DirectoryPollerJob.java:34)
at org.quartz.core.JobRunShell.run(JobRunShell.java:195)
at com.atlassian.multitenant.quartz.MultiTenantThreadPool$MultiTenantRunnable.run(MultiTenantThreadPool.java:72)
at org.quartz.simpl.SimpleThreadPool$WorkerThread.run(SimpleThreadPool.java:520)
2012-10-08 17:56:41,829 QuartzWorker-1 INFO ServiceRunner directory.ldap.cache.RemoteDirectoryCacheRefresher found 2932