I am trying to import an xml backup file created on our production jira instance to a test instance. Eventual aim is to upgrade server hardware and migrate OS platform from linux/mysql to windows/mssql.
When starting the restore we get to about 20% and then get the following error:
Error parsing export file. Your export file is invalid. This may be due to a CDATA bug in older versions of JIRA (http://jira.atlassian.com/browse/JRA-4980). Exception is org.xml.sax.SAXParseException: XML document structures must start and end within the same entity.
I have looked online and found this covered (including in the above reference) however this seems to supposedly been resolved after v3.2? I think? So really does it apply in our scenario?
The size of the xml is just over 500MB. I am not sure if upgrading through the restore is an issue either?
Any help will be greatly appreciated.
Andrew