Hi Team,
Confluence is returning 502 bad gateway error. I have done some analysis from the logs but need some concrete evidences for the exact root cause of the issue.
Can someone help me on the conclusion of the RCA?
I am sharing the logs for the reference.
07-Dec-2022 08:56:05.132 WARNING [Catalina-utility-2] org.apache.catalina.valves.StuckThreadDetectionValve.notifyStuckThreadDetected Thread [http-nio-8090-exec-14 url: /pages/editpage.action; user: nessi] (id=[726]) has been active for [69,133] milliseconds (since [12/7/22 8:54 AM]) to serve the same request for https://confluence.telefonica.de/pages/editpage.action?pageId=72016705 and may be stuck (configured threshold for this StuckThreadDetectionValve is [60] seconds). There is/are [1] thread(s) in total that are monitored by this Valve and may be stuck.
2022-12-07 03:03:31,878 WARN [hz.confluence.cached.thread-7] [hazelcast.nio.tcp.TcpIpConnectionErrorHandler] log [10.110.97.232]:5801 [confluence] [3.12.11] Removing connection to endpoint [10.110.97.63]:5801 Cause => java.net.SocketException {Connection refused to address /10.110.97.63:5801}, Error-Count: 5 2022-10-07 03:03:31,879 WARN [hz.confluence.cached.thread-7] [internal.cluster.impl.MembershipManager] log [10.110.97.232]:5801 [confluence] [3.12.11] Member [10.110.97.63]:5801 - aa73a19d-5bf9-4dd7-b3dd-560159969aab is suspected to be dead for reason: No connection
2022-12-06 14:08:19,905 INFO [Catalina-utility-1] [confluence.cluster.hazelcast.HazelcastClusterManager] startCluster Starting the cluster. 2022-10-06 14:08:19,912 WARN [Catalina-utility-1] [com.hazelcast.instance.HazelcastInstanceFactory] log Hazelcast is starting in a Java modular environment (Java 9 and newer) but without proper access to required Java packages. Use additional Java arguments to provide Hazelcast access to Java internal API. The internal API access is used to get the best performance results. Arguments to be used:
2022-12-07 08:56:26,051 WARN [JIRAMetadataPlugin_AggregateProvider:thread-4] [metadata.jira.helper.JiraMetadataErrorHelper] printError The server 'JIRA' cannot be reached
2022-12-07 08:56:27,483 WARN [JIRAMetadataPlugin_AggregateProvider:thread-5] [metadata.jira.helper.JiraMetadataErrorHelper] printError The server 'JIRA' cannot be reached
2022-12-07 08:56:28,804 WARN [JIRAMetadataPlugin_AggregateProvider:thread-3] [metadata.jira.helper.JiraMetadataErrorHelper] printError The server 'JIRA' cannot be reached
ERROR [JIM Marshaller:thread-678] [extra.jira.util.JiraUtil] checkForErrors Received HTTP 502 from server. Error message: Bad Gateway
Awaiting for the response.
Thank you!