I tried deploying Jira to 2 EC2 instances and both of them shared the same user-data script (they get deployed via an auto-scaling group)- however, this was causing only one instance to path health-checks, essentially whatever instance ran Jira first would pass and the other would fail.
I figured out that the issue was EFS- I was mounting EFS to the home Directory I set for Jira in my user-data script at /var/atlassian/application-data/jira
After removing the command to mount EFS from my user-data script, both instances were running fine and passing health-checks. Now I'm curious, am I utilizing an NFS (AWS EFS) incorrectly by mounting it to the Jira home directory? Is that not how it's used? Should I be creating a separate directory (if so, where should it be located) and copying over certain files to my NFS? What's the common use-case for an NFS with Jira?