After configuring Jira to use SSL/HTTPS via server.xml, restarted Jira and it does not come up. Error in the catalina.out file.
JIRA-Bootstrap INFO [c.a.jira.startup.JiraStartupLogger] Running JIRA startup checks.
JIRA-Bootstrap FATAL [c.a.jira.startup.JiraStartupLogger] Startup check failed. JIRA will be locked.
Even though server.xml was rolled back i,e to HTTP only, Jira still cannot start and throwing same error as above.
If manual editing of server.xml might have caused this issue, so after roll-back tried via Jira config tool but still getting same issue.
Below is the tag manually added the first time.
<Connector SSLEnabled="true" relaxedPathChars="[]|" relaxedQueryChars="[]|{}^\`"<>" acceptCount="100" clientAuth="false" connectionTimeout="20000" disableUploadTimeout="true" enableLookups="false" keyAlias="jira" keystoreFile="/opt/atlassian/jira/ssl/jira.jks" keystorePass="********" keystoreType="JKS" maxHttpHeaderSize="8192" maxSpareThreads="75" maxThreads="150" minSpareThreads="25" port="8443" protocol="org.apache.coyote.http11.Http11NioProtocol" scheme="https" secure="true" sslProtocol="TLS" useBodyEncodingForURI="true"/></Service>
Any insights in resolving this issue is very much appreciated.