Hi
We are running opensuse 11.2, and git 1.8.3.We are team of 4 devs. I usually manage repo on server.
Pre Stash install
There was bare repo at /var/git/project.git which was cloned to each dev's machine. the real project was at /srv/htdocs. Everybody pushed to bare repo and it was me who pulled to /srv/htdocs. All was working fine but one day, after pushing to bare repo, another dev pulled to /srv/htdocs and he got error about permission. While investigating the issue I came across suggestion that I should install gitolite or stash. Stash fely bit more user friendly.
Stash Installation
I followed the steps to install stash. I first installed it on windows machine to get the idea about installation steps. After finishing install on linux machine I created users and repos. Successfully cloned the repo as well. For testing I did change soem comments and pushed. All worked fine. I was happy.
Post Install
My happiness was very short lived. I got call from other dev around 20 min later that he can't access mysql db. We were accessing db over ssh.
At first I thought may be sshd stopped but was surprised to see that it was running fine. so I used
$ssh -vv user@domain
and got server refused to start shell.
It had never happened before. So I checked /etc/sshd_config, which seemed to be fine. Then it came my mind that may be stash has in built ssh server which is conflicting with system sshd.
I checked STASH_HOME/log/catalina.out and found that it does have internal ssh server.
Now my probelm is how to resolve this conflict? I can't even start system sshd after stopping it. I always get 'failed' message.
Please let me know what to do. Am I doing something wrong in above scenario? If I must have to use stash ssh server then how can I enable shell access and where I can configure other settings?
or
How can I safely uninstall stash and start from sctach again?
Thanks for your time
PS: Let me know if you need more info[logs] to better investigate the issue.