Good Afternoon,
I am a newbie to JIRA and have exhausted online resources trying to get the import working.
I have backed up our LIVE JIRA and wanted to import this into our test environment. As best as I can. I had used the same setup to create an test environment in AWS with only one exception. Live system uses SQL Server but our AWS test environment is currently using MYSQL.
Every time I try and import the XML file, the import gets to around 56% and then crashes with the following error message:
Error importing data: org.xml.sax.SAXException: com.atlassian.jira.exception.DataAccessException: org.ofbiz.core.entity.GenericEntityException: while inserting: [GenericEntity:Action][updateauthor,phillips][issue,10977][author,phillips][created,2009-03-10 14:53:29.8][id,14630][type,comment][body,This same error has occurred on OFFDC01: Event Type: Warning Event Source: MSDTC Event Category: SVC Event ID: 53258 Date: 10/03/2009 Time: 9:21:15 AM User: N/A Computer: OFFDC01 Description: MS DTC could not correctly process a DC Promotion/Demotion event. MS DTC will continue to function and will use the existing security settings. Error Specifics: d:\nt\com\complus\dtc\dtc\adme\uiname.cpp:9351, Pid: 1384 No Callstack, CmdLine: C:\WINDOWS\system32\msdtc.exe For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp. Data: 0000: 05 00 07 80 ...€ ][updated,2009-03-10 14:53:29.8] (SQL Exception while executing the following:INSERT INTO jiraaction (ID, issueid, AUTHOR, actiontype, actionlevel, rolelevel, actionbody, CREATED, UPDATEAUTHOR, UPDATED, actionnum) VALUES (?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?) (Incorrect string value: '\xC2\x80 ...' for column 'actionbody' at row 1)) java.lang.Exception: com.atlassian.jira.exception.DataAccessException: org.ofbiz.core.entity.GenericEntityException: while inserting: [GenericEntity:Action][updateauthor,phillips][issue,10977][author,phillips][created,2009-03-10 14:53:29.8][id,14630][type,comment][body,This same error has occurred on OFFDC01: Event Type: Warning Event Source: MSDTC Event Category: SVC Event ID: 53258 Date: 10/03/2009 Time: 9:21:15 AM User: N/A Computer: OFFDC01 Description: MS DTC could not correctly process a DC Promotion/Demotion event. MS DTC will continue to function and will use the existing security settings. Error Specifics: d:\nt\com\complus\dtc\dtc\adme\uiname.cpp:9351, Pid: 1384 No Callstack, CmdLine: C:\WINDOWS\system32\msdtc.exe For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp. Data: 0000: 05 00 07 80 ...€ ][updated,2009-03-10 14:53:29.8] (SQL Exception while executing the following:INSERT INTO jiraaction (ID, issueid, AUTHOR, actiontype, actionlevel, rolelevel, actionbody, CREATED, UPDATEAUTHOR, UPDATED, actionnum) VALUES (?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?) (Incorrect string value: '\xC2\x80 ...' for column 'actionbody' at row 1))
The error message appears to indicate insert issues therefore I assume has something to do with the data. I had ran the clean up tool advised here but with no joy.
https://confluence.atlassian.com/display/JIRA063/Removing+invalid+characters+from+XML+backups
Could someone provide any advise as to what I am missing or doing wrong please?
System Info:
| Base URL | http://jira.Test.local |
| System Date | Friday, 21 Aug 2015 |
| System Time | 23:39:29 +1000 |
| Current Working Directory | \JIRA\JIRA |
| Java Version | 1.8.0_11 |
| Java Vendor | Oracle Corporation |
| JVM Version | 1.8 |
| JVM Vendor | Oracle Corporation |
| JVM Implementation Version | 25.11-b03 |
| Java Runtime | Java(TM) SE Runtime Environment |
| Java VM | Java HotSpot(TM) 64-Bit Server VM |
| User Name | SYDVJIRA01$ |
| User Timezone | Australia/Sydney |
| User Locale | English (Australia) |
| System Encoding | Cp1252 |
| Operating System | Windows Server 2012 6.2 |
| OS Architecture | amd64 |
| Application Server Container | Apache Tomcat/7.0.55 |
| Database type | mssql |
| Database JNDI address | mssql jdbc:jtds:sqlserver://SQL:1433/JIRA |
| Database URL | jdbc:jtds:sqlserver://SQL:1433/JIRA |
| Database version | 10.50.6220 |
| Database driver | jTDS Type 4 JDBC Driver for MS SQL Server and Sybase 1.2.4 |
| External user management | OFF |
| JVM Input Arguments | -Djava.awt.headless=true -Datlassian.standalone=JIRA -Dorg.apache.jasper.runtime.BodyContentImpl.LIMIT_BUFFER=true -Dmail.mime.decodeparameters=true -Dorg.dom4j.factory=com.atlassian.core.xml.InterningDocumentFactory -Dcatalina.home=D:\JIRA\JIRA -Dcatalina.base=D:\JIRA\JIRA -Djava.endorsed.dirs=D:\JIRA\JIRA\endorsed -Djava.io.tmpdir=D:\JIRA\JIRA\temp -Datlassian.plugins.enable.wait=300 -Djava.util.logging.manager=org.apache.juli.ClassLoaderLogManager -Djava.util.logging.config.file=D:\JIRA\JIRA\conf\logging.properties -XX:MaxPermSize=384m exit -Xms512m -Xmx2048m |
| Modified Files | [Installation Type: Standalone] templates/email/subject/issueresolved.vm, templates/email/subject/issuecreated.vm, hash-registry.properties, templates/email/subject/issuereopened.vm, templates/email/subject/issueclosed.vm, templates/email/subject/issueworkstopped.vm, templates/email/subject/issuenotify.vm, templates/email/subject/issueassigned.vm, jira-application.properties, templates/email/subject/issueworkstarted.vm, templates/email/subject/issuedeleted.vm, templates/email/subject/issueworklogdeleted.vm, templates/email/subject/issuecommentedited.vm, templates/email/subject/issueworklogupdated.vm, templates/email/subject/issueupdated.vm, templates/email/subject/issueworklogged.vm, templates/email/subject/issuecommented.vm, templates/email/subject/issuemoved.vm |
| Removed Files | [Installation Type: Standalone] There have been no removed files |
| Clustering | OFF |