Due to employees moving to new teams, their access to Jira is revoked by disabling the 'Active' flag. (Though they are still in the 'jira-users' group).
Occasionally they provide feedback to our support email, but the problem is that despite being inactive, their email is rejected:
Reporter (jf078) does not have permission to create an issue. Message rejected.
Manually changing their email address seems like a dirty solution; is there any other way around this?