Hello,
We are having problems to migrate from server on premise to cloud
Our Infra
- DB: Windows Server 2012 R2 - SQL Server 2012
- APP: Windows Server 2016 - Confluence 6.15.9
- Migration Assistant: 3.3.4
When we open the migration assistant we receive:
Cause
org.apache.velocity.exception.MethodInvocationException: Invocation of method 'getInitialState' in class com.atlassian.migration.agent.web.AppAction threw exception com.atlassian.util.concurrent.LazyReference$InitializationException: javax.persistence.PersistenceException: Failed to update database schema at /templates/app.vm[line 21, column 44]
at org.apache.velocity.runtime.parser.node.ASTIdentifier.execute(ASTIdentifier.java:223)
caused by: com.atlassian.util.concurrent.LazyReference$InitializationException: javax.persistence.PersistenceException: Failed to update database schema
at com.atlassian.util.concurrent.LazyReference.getInterruptibly(LazyReference.java:149)
caused by: javax.persistence.PersistenceException: Failed to update database schema
at com.atlassian.migration.agent.store.jpa.impl.LiquibaseSchemaUpgrader.upgrade(LiquibaseSchemaUpgrader.java:35)
caused by: liquibase.exception.MigrationFailedException: Migration failed for change set META-INF/db-changelog/5-attachment-migration-version.xml::5-attachment-migration-version-drop-index::MPT: Reason: META-INF/db-changelog/master.xml : Index Exists Precondition: MIG_ATTACH_SITE_PROGRESS_IDX on MIG_ATTACHMENT : The database name component of the object qualifier must be the name of the current database.
at liquibase.changelog.ChangeSet.execute(ChangeSet.java:559)
caused by: liquibase.exception.PreconditionErrorException: Precondition Error
at liquibase.precondition.core.IndexExistsPrecondition.check(IndexExistsPrecondition.java:123)
caused by: liquibase.exception.DatabaseException: liquibase.exception.DatabaseException: com.microsoft.sqlserver.jdbc.SQLServerException: The database name component of the object qualifier must be the name of the current database.
at liquibase.snapshot.jvm.ForeignKeySnapshotGenerator.addTo(ForeignKeySnapshotGenerator.java:110)
caused by: liquibase.exception.DatabaseException: com.microsoft.sqlserver.jdbc.SQLServerException: The database name component of the object qualifier must be the name of the current database.
at liquibase.snapshot.ResultSetCache.get(ResultSetCache.java:101)
caused by: com.microsoft.sqlserver.jdbc.SQLServerException: The database name component of the object qualifier must be the name of the current database.
at com.microsoft.sqlserver.jdbc.SQLServerException.makeFromDatabaseError(SQLServerException.java:260)
We have tried the following without luck: Restore the Confluence Cloud Migration Assistant to the default version